Requirements

ATutor Requires:

  • HTTP Web Server. (We highly recommend using Apache)
  • PHP 5.0.2+ with the following libraries installed. (NOTE PHP 5.4+ is not supported in ATutor versions prior to 2.1.1.)
    • --with-apxs2=/usr/local/apache2/bin/apxs
    • --with-mysql
    • --with-zlib
    • --with-curl
    • --enable-mbstring
    • --with-gd
    • --with-jpeg-dir=/usr/lib
  • MySQL - 4.1.10+
  • See the System Software section of the site to download the required software.

Database User

A database user account with the privilege to create databases is required if your database does not already exist. That same user will then need create table privileges as well. See the MySQL chapter How the Privilege System Works for additional information.

Web Browser

ATutor makes use of many current HTML features that are only supported in current Web browsers. Though ATutor will function effectively in older, or text only browsers, we strongly recommend updating your browser to a more recent version. Current versions of FireFox 2+, Opera 8+, and Microsoft Internet Explorer 7+, and Google Chrome work well with ATutor.