MantisBT - ATutor
View Issue Details
0003021ATutorUpgradingpublic2007-04-15 08:402007-04-16 07:44
greg 
user2 
normalmajoralways
closedfixed 
 
1.5.4 
SVN
0003021: upgrade privelges lost
I upgraded from 1.5.3, after which the privilege button in the instructor enrollment manager stopped working. Pressing the button only reloads the page.

Privileges do work in the admin EM


No tags attached.
Issue History
2007-04-15 08:40gregNew Issue
2007-04-15 08:40gregAffects version => SVN
2007-04-15 08:48gregNote Added: 0002437
2007-04-15 08:52gregNote Added: 0002438
2007-04-15 08:57gregNote Edited: 0002437
2007-04-15 10:06gregNote Added: 0002439
2007-04-15 10:08gregNote Added: 0002440
2007-04-15 10:08gregAssigned To => user2
2007-04-15 10:08gregStatusnew => confirmed
2007-04-16 06:13user2Statusconfirmed => resolved
2007-04-16 06:13user2Fixed in Version => 1.5.4
2007-04-16 06:13user2Resolutionopen => fixed
2007-04-16 07:44user2Statusresolved => closed

Notes
(0002437)
greg   
2007-04-15 08:48   
(edited on: 2007-04-15 08:57)
Admin only works if you manually add the privlege to the newly added modules in the modules table. It appears they get insert into the table during upgrade with privileges set to 0. (blog and profile pics were added during the upgrade, are there suposed to be admin privs set for these?

(0002438)
greg   
2007-04-15 08:52   
One extra module, epresence was installed prior to the upgrade.
(0002439)
greg   
2007-04-15 10:06   
Also tried a fresh install of 1.5.4 with no modules. Still the instructor enrollment privileges does not work.
(0002440)
greg   
2007-04-15 10:08   
Problem appears to be in the instructor enrolment manager. Nothing to do with upgrading.