MantisBT - ATutor
View Issue Details
0003436ATutor- no cat -public2008-06-06 12:542008-08-21 08:53
harris 
harris 
normalminoralways
closedfixed 
 
1.6.1 
SVN
0003436: get.php conditional checks differ in php version
Different version of PHP seemed to have different $_SERVER variables, causing the conditional checks to fail.

For instance, PHP 5.2.x and PHP 5.1.x have different PHP_SELF values.

More, 5.1.6 uses
 [ORIG_PATH_TRANSLATED]
 [ORIG_PATH_INFO]
 [ORIG_SCRIPT_NAME]
 [ORIG_SCRIPT_FILENAME]

Whereas 5.2.5 uses
 [PATH_TRANSLATED]
 [PATH_INFO]
 [SCRIPT_NAME]
 [SCRIPT_FILENAME]
No tags attached.
Issue History
2008-06-06 12:54harrisNew Issue
2008-06-06 12:54harrisAffects version => SVN
2008-06-09 06:06harrisNote Added: 0002992
2008-06-09 06:08harrisNote Edited: 0002992
2008-06-09 06:40harrisNote Edited: 0002992
2008-06-09 06:49harrisStatusnew => assigned
2008-06-09 06:49harrisAssigned To => harris
2008-06-09 06:49harrisStatusassigned => resolved
2008-06-09 06:49harrisResolutionopen => fixed
2008-06-09 06:49harrisNote Added: 0002993
2008-06-09 06:50harrisNote Added: 0002994
2008-06-09 06:50harrisFixed in Version => 1.6.1
2008-08-21 08:53gregStatusresolved => closed

Notes
(0002992)
harris   
2008-06-09 06:06   
(edited on: 2008-06-09 06:40)
http://bugs.php.net/bug.php?id=34554 [^]
http://bugs.php.net/bug.php?id=31892 [^]

Apparently it's fixed after 5.2.0

(0002993)
harris   
2008-06-09 06:49   
7599
(0002994)
harris   
2008-06-09 06:50   
7599