MantisBT - ATutor
View Issue Details
0004222ATutorSocialpublic2010-04-21 06:142010-09-22 11:50
harris 
harris 
normalminoralways
closedfixed 
 
2.0 
SVN
0004222: json_encode/ json_decode requires PHP 5.2+
Our requirement page says that we need PHP 5.0+.

The json library isn't available until 5.2+. Need to build a json_encode/ json_decode function for lower versions.

http://www.atutor.ca/view/7/19925/1.html [^]
No tags attached.
Issue History
2010-04-21 06:14harrisNew Issue
2010-04-21 06:14harrisAffects version => SVN
2010-04-21 06:25harrisNote Added: 0004156
2010-04-21 06:30harrisNote Deleted: 0004156
2010-04-21 06:32harrisNote Added: 0004157
2010-04-21 06:42harrisNote Added: 0004158
2010-05-02 14:59gregNote Added: 0004197
2010-05-02 15:00gregStatusnew => assigned
2010-05-02 15:00gregAssigned To => harris
2010-05-06 08:53harrisStatusassigned => resolved
2010-05-06 08:53harrisResolutionopen => fixed
2010-05-06 08:53harrisNote Added: 0004243
2010-05-13 08:29harrisStatusresolved => assigned
2010-05-13 08:29harrisStatusassigned => resolved
2010-05-13 08:29harrisFixed in Version => 2.0
2010-09-22 11:50gregStatusresolved => closed

Notes
(0004157)
harris   
2010-04-21 06:32   
use the JSON_service, and then make a wrapper around it.
(0004158)
harris   
2010-04-21 06:42   
Patcher has its own json.inc.php. Recycle its code.
(0004197)
greg   
2010-05-02 14:59   
Create for 5.2, and have the patcher inc as a backup.
(0004243)
harris   
2010-05-06 08:53   
svn: 9900

include/lib/json.inc.php

note: patcher still uses its own json encoder.