MantisBT - ATutor
View Issue Details
0004807ATutorFile Managerpublic2011-08-04 11:202012-07-26 09:59
harris 
harris 
normalminorhave not tried
closedfixed 
 
2.1 
SVN
svn 11494
0004807: IE9 with no flash causes uploader to fail
This is probably related to http://issues.fluidproject.org/browse/FLUID-4382. [^]

Solution:
If flash is not detected, then use the single uploader.
No tags attached.
html testUploader.html (10,840) 2011-09-01 17:10
http://www.atutor.ca/atutor/mantis/file_download.php?file_id=111&type=bug
Issue History
2011-08-04 11:20harrisNew Issue
2011-08-04 11:20harrisStatusnew => assigned
2011-08-04 11:20harrisAssigned To => harris
2011-08-31 10:07harrisNote Added: 0005311
2011-09-01 17:09harrisNote Added: 0005314
2011-09-01 17:10harrisFile Added: testUploader.html
2011-09-01 17:10harrisNote Edited: 0005314bug_revision_view_page.php?bugnote_id=5314#r24
2011-09-06 16:19harrisNote Added: 0005316
2011-09-09 10:34harrisNote Added: 0005324
2012-07-23 10:48gregSVN Revision# => svn 11494
2012-07-23 10:48gregNote Added: 0005679
2012-07-23 10:48gregStatusassigned => resolved
2012-07-23 10:48gregFixed in Version => 2.1
2012-07-23 10:48gregResolutionopen => fixed
2012-07-26 09:59gregNote Added: 0005720
2012-07-26 09:59gregStatusresolved => closed

Notes
(0005311)
harris   
2011-08-31 10:07   
Added the single uploader back in for ATutor. Use the flash flag and does not rely on fluid.

When the jira is fixed for the uploader, maybe then we don't need our single file uploader.
(0005314)
harris   
2011-09-01 17:09   
(edited on: 2011-09-01 17:10)
It seems like the infusion uploader doesn't load on IE9 when it's used on a different path.

I have attached a testUploader.html file for testing, add this file to the root directory (ie. docs/), and then run it. All the styles and buttons will load but the onclick event is not fired. This could be something to do with flash with relative paths.

(0005316)
harris   
2011-09-06 16:19   
Added a component block into the code:

                components: {
                    strategy: {
                        options: {
                            flashMovieSettings: {
                                flashURL: "<?php echo AT_BASE_HREF; ?>jscripts/infusion/lib/swfupload/flash/swfupload.swf",
                                flashButtonImageURL: "<?php echo AT_BASE_HREF; ?>jscripts/infusion/components/uploader/images/browse.png"
                            }
                        }
                    }
                }

The uploader now load files fine to the queue but returns error complaining that the server is rejecting them.
(0005324)
harris   
2011-09-09 10:34   
svn 11494
(0005679)
greg   
2012-07-23 10:48   
fixed some time past
(0005720)
greg   
2012-07-26 09:59   
close for ATutor 2.1