MantisBT - ATutor
View Issue Details
0004976ATutorAdminpublic2012-04-13 16:082012-07-26 10:00
greg 
greg 
normalminoralways
closedfixed 
 
2.1 
SVN
?
0004976: admin sysprefs timezone setting not working.
The time zone setting in the admins system preferences does not work when -4 is selected.
No tags attached.
related to 0004978closed greg create date broken 
Issue History
2012-04-13 16:08gregNew Issue
2012-04-27 07:44LALNote Added: 0005554
2012-05-30 16:50gregNote Added: 0005561
2012-05-31 09:42gregRelationship addedrelated to 0004978
2012-06-04 16:40gregSVN Revision# => ?
2012-06-04 16:40gregNote Added: 0005565
2012-06-04 16:40gregStatusnew => resolved
2012-06-04 16:40gregFixed in Version => 2.1
2012-06-04 16:40gregResolutionopen => fixed
2012-06-04 16:40gregAssigned To => greg
2012-07-26 10:00gregNote Added: 0005771
2012-07-26 10:00gregStatusresolved => closed

Notes
(0005554)
LAL   
2012-04-27 07:44   
Likewise, the system preferences when set to +1 goes a further hour. For example, when time is 2:56pm when set to +1, it should be 3:56pm but instead it displays 4:56. Thanks
(0005561)
greg   
2012-05-30 16:50   
restting all, be sure to set the default timezone using date_default_timezone_set('UTC');
 in vitals, but replace UTC with the detected timezone of the server. (if possible)
(0005565)
greg   
2012-06-04 16:40   
replaced current timezone setting with an incremented version for now. It works, but is still not optimal. Convert the timezone selector to the PHP timezone functions when we up the php version requirement to 5.3 at some time in the future
(0005771)
greg   
2012-07-26 10:00   
closed for ATutor 2.1