MantisBT - ATutor
View Issue Details
0004978ATutorAdminpublic2012-04-15 18:192012-07-26 10:00
greg 
greg 
normalminoralways
closedfixed 
2.0.3 
2.1 
SVN
fdf177c..7b89c82 atutor_2_0_3-multisite -> atutor_2_0_3-multisite
0004978: create date broken
in the multisite branch, the created date displayed in the admin's courses table, shows a negative 5 digit number. using

echo AT_date($startend_date_long_format, $row['created_date'], AT_DATE_UNIX_TIMESTAMP)

themes/default/admin/courses/courses.tmpl.php

changing to just echo $row['created_date'] fixes the problem, but why?

Could be the services module create_course.php file?

this does not seem to be a problem on the 2.0.3 demo site however.

No tags attached.
related to 0004976closed greg admin sysprefs timezone setting not working. 
Issue History
2012-04-15 18:19gregNew Issue
2012-04-15 18:27gregNote Added: 0005553
2012-05-29 15:58gregNote Added: 0005560
2012-05-31 09:42gregRelationship addedrelated to 0004976
2012-06-04 16:38gregSVN Revision# => fdf177c..7b89c82 atutor_2_0_3-multisite -> atutor_2_0_3-multisite
2012-06-04 16:38gregNote Added: 0005564
2012-06-04 16:38gregStatusnew => resolved
2012-06-04 16:38gregFixed in Version => 2.1
2012-06-04 16:38gregResolutionopen => fixed
2012-06-04 16:38gregAssigned To => greg
2012-07-26 10:00gregNote Added: 0005772
2012-07-26 10:00gregStatusresolved => closed

Notes
(0005553)
greg   
2012-04-15 18:27   
more likely $startend_date_long_format is not defined.
(0005560)
greg   
2012-05-29 15:58   
Could not reproduce
(0005564)
greg   
2012-06-04 16:38   
added language token to date format string in courses.tmpl.php
(0005772)
greg   
2012-07-26 10:00   
cloase for ATutor 2.1