MantisBT - ATutor
View Issue Details
0000737ATutorContentpublic2004-06-05 05:132005-11-29 08:29
greg 
user2 
normalminoralways
closedfixed 
 
1.5.2 
0000737: 1.4 code code breaks with URL
Could not make the atutor [code][/code] work with a URL. the http:// appear to get converted to a link thus breaking the code.
No tags attached.
Issue History
2004-06-05 05:13gregNew Issue
2004-06-05 05:13gregApache Version => 1.3.x
2004-06-05 05:13gregPHP Version => 4.3.2
2004-06-05 05:39gregSummary1.4 code code still broken => 1.4 code code breaks with URL
2004-06-05 05:39gregDescription Updated
2004-06-22 12:15heidiNote Added: 0000489
2004-07-06 15:46gregNote Added: 0000545
2004-07-29 11:55user2Note Added: 0000555
2005-07-25 06:46heidiNote Added: 0001481
2005-07-25 08:24jonNote Added: 0001487
2005-11-22 10:57user2Note Added: 0001624
2005-11-22 10:57user2Note Deleted: 0001481
2005-11-22 10:57user2Note Deleted: 0001487
2005-11-22 10:57user2Note Deleted: 0000545
2005-11-22 11:15user2Statusnew => resolved
2005-11-22 11:15user2Fixed in Version => 1.5.2
2005-11-22 11:15user2Resolutionopen => fixed
2005-11-22 11:15user2Assigned To => user2
2005-11-29 08:29user2Statusresolved => closed

Notes
(0000489)
heidi   
2004-06-22 12:15   
also for inbox:

msg:
[code]
<?php echo "something";?>
<a href="http://place.com" [^] />
[/code]

shows up as:



<?php echo "something";?>

<a href="http://place.com" [^] />



(click reply and back to original in reply box)
(0000555)
user2   
2004-07-29 11:55   
use Savant::filter->colorizeCode()
(0001624)
user2   
2005-11-22 10:57   
only breaks when formatting is set to TEXT (rather than HTML)

html gets escaped twice.