MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002285ATutorModulespublic2006-01-05 07:142006-05-02 06:18
Reporteruser2 
Assigned Touser2 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version1.5.3 
Summary0002285: new modules in svn
Descriptionwhy aren't the new modules in SVN?

DONE in the phpmyadmin module change all mysql_query($sql) to mysql_query($sql, $db).

DONE and $phpmyadmin_url = addslashes(stripslashes($_REQUEST['phpmyadmin_url'])); isn't correct if magic_quotes isn't enabled.

DONE and shouldn't be using INSERT and UPDATE. a single REPLACE will do.

DONE and don't use select *. and don't use mysql_fetch_array()

DONE and use correct indenting and alternate if-statement notation within HTML.

DONE and buttons shouldn't be so verbose. "Save" "Open" is enough. no need for "Save phpMyAdmin Location" language.

DONE and no need to define AT_PRIV_PHPMYADMIN since there is no instructor priv.

DONE and phpmyadmin should NOT be an assignable privilege! any admin with such priv can just get the password of any super admin or even change their priv.
TagsNo tags attached.
Affects version
SVN Revision#
Attached Files

- Relationships

-  Notes
(0001729)
user2
2006-01-05 10:11

phpmyadmin doesn't have a cancel button when editing.

the form divs aren't nested correctly.

why not just have the edit form within the edit box? could do the same thing.
(0001730)
user2
2006-01-05 10:12
edited on: 2006-01-05 11:26

DONE phpmyadmin selects from the db to get the config data. that's not needed.

(0001734)
user2
2006-01-06 07:34

same issues with the ccnet module.

- Issue History
Date Modified Username Field Change
2006-01-05 07:14 user2 New Issue
2006-01-05 07:16 user2 Description Updated
2006-01-05 10:11 user2 Note Added: 0001729
2006-01-05 10:12 user2 Note Added: 0001730
2006-01-05 11:26 user2 Description Updated
2006-01-05 11:26 user2 Note Edited: 0001730
2006-01-06 07:34 user2 Note Added: 0001734
2006-01-06 09:45 user2 Status new => resolved
2006-01-06 09:45 user2 Fixed in Version => 1.5.3
2006-01-06 09:45 user2 Resolution open => fixed
2006-01-06 09:45 user2 Assigned To => user2
2006-05-02 06:18 user2 Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker