MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002538ATutorTests/Surveyspublic2006-06-20 05:222006-06-27 06:02
Reporterheidi 
Assigned Touser2 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionno change required 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version1.5.3 
Summary0002538: multiple choice test marking
Description(from tony - june 19)
3) View Results of multiple choice quiz:

This feature is not working at all. Depending of when you try, you get any of the following errors when you view the results:

A) A red X for the wrong choice but NO green tick mark next to the right choice you should have chosen (as it should be)

B) The order of the questions in the quiz is different from the order of the questions in the View Results area. So what used to be (for example) Question 1 in the initial quiz, now is Question 7, and so on

C) Sometimes the system gives a red X to a choice that is in fact correct (and which should be getting a green check mark). We know this because we checked the original file with the answers. So a correct answer is marked as wrong even though it is clearly chosen as a "right" option in the question bank.

D) Sometimes, if you choose the wrong answer, you then can see the wrong answer (as a red X) plus the correct answer (as a green check mark). Sometimes it only shows the wrong answer. Sometimes is shows only the wrong answer, but it is not the option you actually chose

E) Sometimes it is not showing the answer you chose but only the correct answer, BUT displayed as a red X instead of a green check mark!!!!

F) Sometimes it shows the correct answer AND the wrong answer but BOTH as red Xs!!!!

As you can see, this feature is just not working at all at the moment.

4) The time on the "date stamp" for the time you took a test seems to be off a bit. Is that something to do with Prime Signal's server rather than ATutor?
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships
related to 0002547closeduser2 test marking 

-  Notes
(0001994)
user2
2006-06-21 12:58

most of the report is bogus.

a few bugs seem more serious than they are, but fixed.

also need to fix the instructor view.
(0002002)
greg (administrator)
2006-06-22 12:47

Correct answers still seem to be marked wrong. And when a T/F question is answered incorrectly, both choices are marked with a red X. See how the marks are displayed correctly in 1.5, in the installation I've setup at:

http://greg-pc.atrc.utoronto.ca/ATutor/ [^]
login greg:greg
(0002003)
user2
2006-06-22 13:04

that is not a bug, that is a design feature that is unrelated.

post another issue for that "feature".
(0002004)
greg (administrator)
2006-06-22 13:12

This is pretty much the problem described in this bug (3A-F). Check marks and Xs are confusing. The design should be as it is in 1.5.

When the choosen answer is wrong:
X between the radio/checkbox and the question number, and a green checkmark in parentheses following the right answer.

When the chosen answer is correct:
checkmrk between the radio/checkbox and the question number

- Issue History
Date Modified Username Field Change
2006-06-20 05:22 heidi New Issue
2006-06-20 05:22 heidi Affects version => SVN
2006-06-21 12:58 user2 Note Added: 0001994
2006-06-22 10:09 user2 Status new => resolved
2006-06-22 10:09 user2 Fixed in Version => 1.5.3
2006-06-22 10:09 user2 Resolution open => fixed
2006-06-22 10:09 user2 Assigned To => user2
2006-06-22 12:47 greg Note Added: 0002002
2006-06-22 12:47 greg Status resolved => assigned
2006-06-22 13:04 user2 Note Added: 0002003
2006-06-22 13:12 greg Note Added: 0002004
2006-06-23 05:10 heidi Relationship added related to 0002547
2006-06-23 06:05 user2 Status assigned => resolved
2006-06-23 06:05 user2 Resolution fixed => no change required
2006-06-27 06:02 user2 Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker