MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002670ATutor- no cat -public2006-07-19 13:022006-08-04 08:45
Reportergreg 
Assigned Touser2 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version1.5.3.2 
Summary0002670: mysql 5 join issue
DescriptionReported possible sql error in bounce.php

http://atutor.ca/view/7/3590/1.html [^]
Additional Informationfor some reason mysql 5 doesn't like this join.

To (new):
$sql = "SELECT G.group_id FROM ".TABLE_PREFIX."groups G, ".TABLE_PREFIX."groups_types T, ".TABLE_PREFIX."groups_members M WHERE G.type_id=T.type_id AND G.group_id=M.group_id AND T.course_id=$course_id AND M.member_id=$_SESSION[member_id]";

From (bad):
$sql = "SELECT G.group_id FROM ".TABLE_PREFIX."groups G INNER JOIN ".TABLE_PREFIX."groups_types T, ".TABLE_PREFIX."groups_members M ON (G.type_id=T.type_id AND G.group_id=M.group_id) WHERE T.course_id=$course_id AND M.member_id=$_SESSION[member_id]";
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships

-  Notes
(0002126)
greg (administrator)
2006-07-24 12:37

seems to be happening for others

see:
http://www.atutor.ca/view/7/8464/1.html [^]
(0002129)
user2
2006-07-27 08:55

couldn't get mysql 5 to work (on my machine with php).

- Issue History
Date Modified Username Field Change
2006-07-19 13:02 greg New Issue
2006-07-19 13:02 greg Affects version => 1.5.3
2006-07-24 08:05 user2 Affects version 1.5.3 => SVN
2006-07-24 08:05 user2 Summary bounce sql error? => mysql 5 join issue
2006-07-24 08:05 user2 Additional Information Updated
2006-07-24 12:37 greg Note Added: 0002126
2006-07-27 08:55 user2 Note Added: 0002129
2006-07-28 09:02 user2 Status new => resolved
2006-07-28 09:02 user2 Fixed in Version => 1.5.3.2
2006-07-28 09:02 user2 Resolution open => fixed
2006-07-28 09:02 user2 Assigned To => user2
2006-08-04 08:45 user2 Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker