MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002764ATutorModulespublic2006-09-20 04:532006-11-20 08:16
Reportergreg 
Assigned Toheidi 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version1.5.3.3 
Summary0002764: Links privilege missing
DescriptionCourse members with the links privilege are unable to manage links.
Additional InformationPost a fix to the thread started by Vegard
http://atutor.ca/view/3/8828/1.html [^]
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships

-  Notes
(0002191)
user2
2006-09-20 07:44

there's no easy solution or easy way to patch this.

i think some of it has to be restructured and the logic "re-thinked".

links priv is not being used. group priv seems to be used instead.
(0002237)
heidi (developer)
2006-11-06 09:01

had to fix a bunch of things, so there's no post-able solution.

right now:
groups priv = person can manage all group links
group member = can manage your group's links
links priv = can manage course links

group priv ppl cannot be in groups
everyone else (incl those w/ other privs) can.

- Issue History
Date Modified Username Field Change
2006-09-20 04:53 greg New Issue
2006-09-20 04:53 greg Affects version => SVN
2006-09-20 07:44 user2 Note Added: 0002191
2006-10-30 09:01 heidi Status new => assigned
2006-10-30 09:01 heidi Assigned To => heidi
2006-11-06 09:01 heidi Status assigned => resolved
2006-11-06 09:01 heidi Fixed in Version => 1.5.3.3
2006-11-06 09:01 heidi Resolution open => fixed
2006-11-06 09:01 heidi Note Added: 0002237
2006-11-20 08:16 user2 Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker