MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002912ATutorFHApublic2007-02-12 08:592007-02-13 09:16
Reporteruser2 
Assigned Touser2 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version1.5.4 
Summary0002912: guest tests
Descriptionmake it so that guests can take a test w/o saving it to the database.

they'll click Save, then be taken to a page asking them to click on another button. that 2nd page will hide the test results in a hidden form. the subsequent page will then convert the POST data to data that looks like it comes from the database as $rows, and pass those to the question objects to show the result and mark.
Additional Informationor is it best to just save the data to the db anyway.

the big question is: will guests and logged-in/enrolled students be taking the same tests? would being able to view stats from guests be desirable? (i think so!)
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships

-  Notes
(0002334)
user2
2007-02-12 09:01

could this feature resolve the anonymous test problem, where it is possible to turn off 'anonymous' to reveal the test takers? (but that doesn't limit the number of times someone can take the test).

- Issue History
Date Modified Username Field Change
2007-02-12 08:59 user2 New Issue
2007-02-12 08:59 user2 Affects version => SVN
2007-02-12 09:00 user2 Description Updated
2007-02-12 09:00 user2 Additional Information Updated
2007-02-12 09:01 user2 Note Added: 0002334
2007-02-12 09:59 user2 Status new => assigned
2007-02-12 09:59 user2 Assigned To => user2
2007-02-13 07:14 user2 Status assigned => resolved
2007-02-13 07:14 user2 Fixed in Version => 1.5.4
2007-02-13 07:14 user2 Resolution open => fixed
2007-02-13 09:16 user2 Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker