MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003166ATutorContentpublic2007-08-24 13:242008-08-21 08:57
Reportergreg 
Assigned Togreg 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version1.6.1 
Summary0003166: media tag displays in announcement
DescriptionEmbedded a media tag with a YouTube URL into an announcement, and the media tags display before and after the YouTube movie when displayed.
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships

-  Notes
(0002559)
greg (administrator)
2007-08-24 13:32
edited on: 2007-08-24 13:37

also happens else where for YouTube, content, forums

(0002560)
IndieRect (reporter)
2007-08-26 22:01

The reason is that a regexp in the parsing routine matches only the URL itself, w/o tags. So YouTube links would be converted into videos even without [media] tags.
(0002796)
greg (administrator)
2008-02-11 06:12
edited on: 2008-02-11 06:18

media tag is still appearing with YouTube movies.

update with
    
$text = preg_replace("#\[media\]http://(www.)?youtube.com/watch\?v=([a-z0-9_-]+)\[/media\]#i", [^] '<object width="425" height="350"><param name="movie" value="http://www.youtube.com/v/\\2"></param><embed [^] src="http://www.youtube.com/v/\\2" [^] type="application/x-shockwave-flash" width="425" height="350"></embed></object>', $text);

(0002797)
greg (administrator)
2008-02-11 06:32

Committed revision 7283.

- Issue History
Date Modified Username Field Change
2007-08-24 13:24 greg New Issue
2007-08-24 13:24 greg Affects version => SVN
2007-08-24 13:32 greg Note Added: 0002559
2007-08-24 13:37 greg Note Edited: 0002559
2007-08-26 22:01 IndieRect Note Added: 0002560
2007-08-27 06:17 user2 Status new => resolved
2007-08-27 06:17 user2 Resolution open => no change required
2007-08-27 06:17 user2 Assigned To => user2
2008-02-11 06:12 greg Note Added: 0002796
2008-02-11 06:12 greg Assigned To user2 =>
2008-02-11 06:12 greg Status resolved => new
2008-02-11 06:18 greg Note Edited: 0002796
2008-02-11 06:32 greg Status new => resolved
2008-02-11 06:32 greg Fixed in Version => 1.6.1
2008-02-11 06:32 greg Resolution no change required => fixed
2008-02-11 06:32 greg Assigned To => greg
2008-02-11 06:32 greg Note Added: 0002797
2008-08-21 08:57 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker