MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003202ATutor- no cat -public2007-11-28 05:072010-09-22 11:50
Reportergreg 
Assigned Toharris 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionwon't fix 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0003202: non latin glossary term
Descriptionnon-latin glossary terms in pages are not recognized.

item 6
http://www.atutor.ca/view/3/12062/1.html [^]
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships
related to 0003511closedgreg Non-latin glossary terms absent from side menu 

-  Notes
(0002860)
harris (developer)
2008-05-05 05:53

Some charset have their unique way of representing '?'. Need a way to tell the system what a question mark is.
ie. ?, ?, ?
represent
English, Chinese, Japanese question mark.

Needs to generalize all question mark to the iso88591 '?'.
(0003234)
harris (developer)
2008-10-17 09:32

http://www.atutor.ca/view/7/15535/1.html [^]

bump
(0003235)
harris (developer)
2008-10-17 10:17

http://www.wintranslation.com/articles/art05_0009_punctuation.htm [^]

Not all question marks in the world's languages have the same shape. I guess the ASCII '?' is the only way. Unless we do a mapping on all 'question mark', but I don't think that's necessary. Users can always use the 'Add Term' link at the bottom to add a glossary term, the link will generate a ASCII based [?][/?].
(0003236)
IndieRect (reporter)
2008-10-20 23:50

Just a thought:
IMO, users would rather _not_ use the link because it's added to the end of the text, not inserted where the cursor is. So it's simpler to just type in the [?][/?] tags, especially if you're editing a text and not creating it from scratch.
(0004205)
greg (administrator)
2010-05-02 15:31

is this resolvable for 2.0?
(0004225)
harris (developer)
2010-05-04 06:08

We can potentially have a question marks mapping that maps all the world's question marks. Then preg_match the question mark everytime.
(0004227)
harris (developer)
2010-05-04 07:10

But non-latin terms are recognized.
(0004237)
harris (developer)
2010-05-04 12:29

terms with slashes and special patterns are not recognized.
(0004242)
harris (developer)
2010-05-06 06:56

non-latin glossary terms in pages are recognized.

- Issue History
Date Modified Username Field Change
2007-11-28 05:07 greg New Issue
2007-11-28 05:07 greg Affects version => SVN
2008-04-30 07:01 cindy Status new => assigned
2008-04-30 07:01 cindy Assigned To => harris
2008-05-05 05:53 harris Note Added: 0002860
2008-10-01 06:56 harris Relationship added related to 0003511
2008-10-17 09:32 harris Note Added: 0003234
2008-10-17 10:17 harris Note Added: 0003235
2008-10-20 23:50 IndieRect Note Added: 0003236
2010-05-02 15:31 greg Note Added: 0004205
2010-05-04 06:08 harris Note Added: 0004225
2010-05-04 07:10 harris Note Added: 0004227
2010-05-04 12:29 harris Note Added: 0004237
2010-05-06 06:56 harris Status assigned => resolved
2010-05-06 06:56 harris Resolution open => won't fix
2010-05-06 06:56 harris Note Added: 0004242
2010-09-22 11:50 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker