MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003252ATutorUpgradingpublic2007-12-17 06:592008-08-21 08:58
Reporterharris 
Assigned Toharris 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.6 
Target VersionFixed in Version1.6 
Summary0003252: Database upgrade increases the database size.
DescriptionThe field sizes can be reduced to TEXT instead of MEDIUMTEXT.

http://www.atutor.ca/view/3/12062/1.html [^]
Additional InformationVARCHAR is 2^8 (for mysql <= 5)
TEXT is 2^16
MEDIUMTEXT is 2^32

Multiplying 2^8 by 4 is still 2^10, it should be TEXT instead.

Moreover, some fields like real_name, title can even be in VARCHAR(255), because ASCII characters are mostly in 1-byte, and there is really no need for a title to be in TEXT.
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships

-  Notes
(0002658)
harris (developer)
2007-12-17 07:01

probably name-related, and title-related should remain the same size.

comments/description has to be in text.
(0002659)
harris (developer)
2007-12-17 07:23

7168

- Issue History
Date Modified Username Field Change
2007-12-17 06:59 harris New Issue
2007-12-17 06:59 harris Affects version => SVN
2007-12-17 07:01 harris Note Added: 0002658
2007-12-17 07:22 harris Status new => assigned
2007-12-17 07:22 harris Assigned To => harris
2007-12-17 07:23 harris Status assigned => resolved
2007-12-17 07:23 harris Fixed in Version => 1.6
2007-12-17 07:23 harris Resolution open => fixed
2007-12-17 07:23 harris Note Added: 0002659
2008-08-21 08:58 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker