MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003300ATutorTests/Surveyspublic2008-01-24 01:012008-08-21 08:54
ReporterIndieRect 
Assigned Toharris 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.6 
Target VersionFixed in Version1.6.1 
Summary0003300: Test intro page is available when a test is not
DescriptionATutor version: 1.6 RC1

Even if students cannot take some test because of its expiry or used up attempts, they can view tools/test_intro.php for that test. It can be done by typing in the correct URL.
Not a big problem, but since it is supposed to be protected (as I can say from the code), then it needs to be.

I suggest a refactoring approach to fixing this and improving the overall readability of authentication code in the test area: http://www.atutor.ca/view/12/12652/1.html. [^]
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships

-  Notes
(0002916)
harris (developer)
2008-05-14 09:33

Perform a similar check like take_test.php
(0002917)
harris (developer)
2008-05-14 09:34

7530

- Issue History
Date Modified Username Field Change
2008-01-24 01:01 IndieRect New Issue
2008-01-24 01:01 IndieRect Affects version => SVN
2008-04-30 06:39 cindy Status new => assigned
2008-04-30 06:39 cindy Assigned To => harris
2008-05-14 09:33 harris Note Added: 0002916
2008-05-14 09:34 harris Status assigned => resolved
2008-05-14 09:34 harris Fixed in Version => 1.6.1
2008-05-14 09:34 harris Resolution open => fixed
2008-05-14 09:34 harris Note Added: 0002917
2008-08-21 08:54 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker