MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003330ATutorUpgradingpublic2008-03-13 07:312008-08-21 08:56
Reporterharris 
Assigned Toharris 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version1.6.1 
Summary0003330: Timestamp updated during UTF8 conversion
Descriptionhttp://www.atutor.ca/forums/view.php?fid=3;pid=13090;f=40 [^]
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships

-  Notes
(0002803)
harris (developer)
2008-03-13 07:33

The cause lies in the table column attribute: 'ON UPDATE CURRENT_TIMESTAMP'

Each successful 'update' (by successful, it means the SQL returns Affected: >0 after an update) will trigger that clause, and update the timestamp to CURRENT_TIMESTAMP (aka NOW()).

ps. Triggers also in REPLACE.
(0002804)
harris (developer)
2008-03-13 08:31

update ... SET timestamp=old_timestamp during conversion
(0002805)
harris (developer)
2008-03-13 08:51

7338

- Issue History
Date Modified Username Field Change
2008-03-13 07:31 harris New Issue
2008-03-13 07:31 harris Affects version => SVN
2008-03-13 07:33 harris Note Added: 0002803
2008-03-13 08:31 harris Note Added: 0002804
2008-03-13 08:50 harris Severity minor => major
2008-03-13 08:50 harris Status new => assigned
2008-03-13 08:50 harris Assigned To => harris
2008-03-13 08:51 harris Status assigned => resolved
2008-03-13 08:51 harris Fixed in Version => 1.6.1
2008-03-13 08:51 harris Resolution open => fixed
2008-03-13 08:51 harris Note Added: 0002805
2008-08-21 08:56 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker