MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003405ATutorTests/Surveyspublic2008-05-21 09:582008-08-21 08:54
Reportercindy 
Assigned Tocindy 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.6.1 
Target VersionFixed in Version1.6.1 
Summary0003405: "Divide by Zero" warning in tests that use pass percentage but questions' weights have not been set
DescriptionIf the test is defined to use pass percentage but the weights of the questions in the test haven't been set, "Warning: Division by zero in /opt/lampp/htdocs/at161/tools/view_results.php on line 122" occurs.

This is because the calculation of test result, in percentage, is calculated by test_score/total_weight. total_weight is 0 in this case.
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships

-  Notes
(0002944)
cindy (administrator)
2008-05-21 09:59

Affected script: tools/view_results.php

If test uses pass percentage and total_weight is 0, don't display any feedback.

- Issue History
Date Modified Username Field Change
2008-05-21 09:58 cindy New Issue
2008-05-21 09:58 cindy Affects version => SVN
2008-05-21 09:59 cindy Status new => resolved
2008-05-21 09:59 cindy Fixed in Version => 1.6.1
2008-05-21 09:59 cindy Resolution open => fixed
2008-05-21 09:59 cindy Assigned To => cindy
2008-05-21 09:59 cindy Note Added: 0002944
2008-08-21 08:54 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker