MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003526ATutorPatcherpublic2008-07-28 06:522009-07-21 08:52
Reportergreg 
Assigned Tocindy 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version1.6.2 
Summary0003526: Patcher author field
DescriptionThere needs to be an author field added to patch.xml for the next release
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships

-  Notes
(0003116)
IndieRect (reporter)
2008-08-05 21:45

I also suggest adding a date/time field: it's of interest for developers, and also an admin having missed a critical patch might want to check logs for suspicious activity since that patch.
(0003379)
cindy (administrator)
2008-11-17 05:36

Solution: new fields "author" and "installed_date" are added into table "patches"

SVN Revision: 8231

Affected files:
install/db/atutor_schema.sql
install/db/atutor_upgrade_1.6.1_to_1.6.2.sql
mods/_standard/patcher/classes/Patch.class.php
mods/_standard/patcher/classes/PatchListParser.class.php
mods/_standard/patcher/index_admin.php
mods/_standard/patcher/sample_patch.xml
mods/_standard/patcher/sample_patch_list.xml

- Issue History
Date Modified Username Field Change
2008-07-28 06:52 greg New Issue
2008-07-28 06:52 greg Affects version => SVN
2008-08-05 21:45 IndieRect Note Added: 0003116
2008-11-13 10:10 greg Status new => assigned
2008-11-13 10:10 greg Assigned To => cindy
2008-11-17 05:36 cindy Status assigned => resolved
2008-11-17 05:36 cindy Fixed in Version => 1.6.2
2008-11-17 05:36 cindy Resolution open => fixed
2008-11-17 05:36 cindy Note Added: 0003379
2009-07-21 08:52 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker