MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003530ATutor- no cat -public2008-08-07 05:242008-08-21 09:33
Reportercindy 
Assigned Tocindy 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version1.6.1 
Summary0003530: Patcher: cannot install patch when mysql is in strict mode
DescriptionWhen mysql is in strict mode, installing patch gives error "Field 'remove_permission_files' doesn't have a default value".

Refer to http://www.atutor.ca/view/7/14603/1.html [^]
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships

-  Notes
(0003117)
cindy (administrator)
2008-08-07 05:27

SVN revision: 7780

The problem is when mysql is set to strict mode. It seems you cannot set a default value on a text / blob. AND, since there is no default value, and the query isn't setting a value, mysql chokes up. To fix this issue, add fields "remove_permission_files", "backup_files", "patch_files" to the insert queries in the createPatchesRecord() function in mods/_standard/patcher/classes/Patch.class.php

- Issue History
Date Modified Username Field Change
2008-08-07 05:24 cindy New Issue
2008-08-07 05:24 cindy Affects version => SVN
2008-08-07 05:27 cindy Status new => resolved
2008-08-07 05:27 cindy Fixed in Version => 1.6.1
2008-08-07 05:27 cindy Resolution open => fixed
2008-08-07 05:27 cindy Assigned To => cindy
2008-08-07 05:27 cindy Note Added: 0003117
2008-08-21 09:33 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker