MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003536ATutorAdminpublic2008-08-20 23:182009-11-05 11:11
ReporterIndieRect 
Assigned Togreg 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.6.2 
Target VersionFixed in Version1.6.4 
Summary0003536: Rogue variables in admin/config_edit.php
DescriptionThere're some uninitialized vars in admin/config_edit.php:
    * $_config_defaults['require_email_confirmation'] -- should be just $_config_defaults['email_confirmation']
    * $disabled
    * $disable_on
    * $disable_off
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships

-  Notes
(0003133)
greg (administrator)
2008-08-21 05:47

Corrected email_confirmation default config var.

Not sure what disable_on and disable_off are supposed to do. It looks like they can safely be removed.
(0003134)
IndieRect (reporter)
2008-08-21 06:10
edited on: 2008-08-21 06:19

Agree. Those must be some debug vars without any other mention in the file even when they've been introduced in r5519.

$disabled has been left off since r3644. Back then it was used to flag unwritable config.inc.php. Later mutable configuration data were moved to AT_config table and the file needed not to be writable anymore (in fact, forced to be read-only during installation); so the var was deleted, except for this instance.

(0003135)
greg (administrator)
2008-08-21 06:30

cleaned up unintialized vars and broken default config for email confirmation
(0003750)
IndieRect (reporter)
2009-08-12 01:09
edited on: 2009-08-12 01:12

It's back.
Apparently, the fix introduced in r7793 and r7794 has been reverted entirely in r7849, the very next committed change to this file.

Please fix it once more, from the very beginning.

(0003833)
greg (administrator)
2009-11-05 10:26

Committed revision 8883. removed rogue vars again.

- Issue History
Date Modified Username Field Change
2008-08-20 23:18 IndieRect New Issue
2008-08-20 23:18 IndieRect Affects version => SVN
2008-08-21 05:47 greg Note Added: 0003133
2008-08-21 06:10 IndieRect Note Added: 0003134
2008-08-21 06:19 IndieRect Note Edited: 0003134
2008-08-21 06:30 greg Status new => resolved
2008-08-21 06:30 greg Fixed in Version => 1.6.2
2008-08-21 06:30 greg Resolution open => fixed
2008-08-21 06:30 greg Assigned To => greg
2008-08-21 06:30 greg Note Added: 0003135
2008-08-21 09:33 greg Status resolved => closed
2009-08-12 01:09 IndieRect Status closed => feedback
2009-08-12 01:09 IndieRect Resolution fixed => reopened
2009-08-12 01:09 IndieRect Note Added: 0003750
2009-08-12 01:12 IndieRect Note Edited: 0003750
2009-11-05 10:26 greg Status feedback => resolved
2009-11-05 10:26 greg Fixed in Version 1.6.2 => 1.6.4
2009-11-05 10:26 greg Resolution reopened => fixed
2009-11-05 10:26 greg Note Added: 0003833
2009-11-05 11:11 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker