MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003556ATutorUpgradingpublic2008-09-07 00:082008-11-14 08:22
ReporterIndieRect 
Assigned Toharris 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.6.1 
Target VersionFixed in Version1.6.2 
Summary0003556: Repetitive table alterations during upgrade
DescriptionIf altering some tables on upgrade step 2 fails and user presses "Retry" then the upgrade script seems to repeat altering ALL tables, not only those that failed.

In 1.6.1pl1 it may cause an inability to log in:
I had to press the button several times, and, as a result, found passwords in the DB to be equal to sha1(sha1(sha1(sha1(password)))).

Suggestion:
If altering any tables on upgrade step 2 fails, the script should retry altering only those tables, not all.
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships

-  Notes
(0003166)
harris (developer)
2008-09-08 07:56

So this is what causes some failures on users log in.

Thanks for finding this out.
(0003290)
harris (developer)
2008-11-10 09:28

ustep2 runs through a series of sql statements through the .sql file. When a query failed and the user was asked to retry, all the .sql files will be run again and thus the repeated password encryption.

A quick fix to this is to run the encryption line iff the ||password|| < 40, because only then the pre161 non-SHA1 encrypted password will be converted. Given that the db password length was only 20.


8194

- Issue History
Date Modified Username Field Change
2008-09-07 00:08 IndieRect New Issue
2008-09-07 00:08 IndieRect Affects version => SVN
2008-09-08 07:56 harris Note Added: 0003166
2008-11-10 09:25 harris Status new => assigned
2008-11-10 09:25 harris Assigned To => harris
2008-11-10 09:28 harris Status assigned => resolved
2008-11-10 09:28 harris Fixed in Version => 1.6.2
2008-11-10 09:28 harris Resolution open => fixed
2008-11-10 09:28 harris Note Added: 0003290
2008-11-14 08:22 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker