MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003613ATutorContentpublic2008-10-24 09:222008-11-14 08:22
Reportergreg 
Assigned Tocindy 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version1.6.2 
Summary0003613: Duplicate Original Resources via [media]
DescriptionUsing an inserted swf file with the [media] tag, the file is listed four times under alt content. The file name does appear four times in the source code, which is necessary as alt to object if not supported, and in the param element (which may not be necessary). What can we do to eliminate the duplicates, without loosing a second instance of the file if it is purposely inserted a second time using another [media] tag.
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships

-  Notes
(0003256)
silvia (developer)
2008-10-28 16:25

I've changed alternatives.inc.php and this partially solved such a problem.
Unfortunally, due to the <object> "nature" and to the "automatically" provision of a <a> as a child of each <object>, it is not possible to reduce the number of repeatetion less than two (one is related to the data attribute of the <object> and the other one is related to the href attribute of the <a>).
(0003277)
cindy (administrator)
2008-11-03 06:50

SVN Revision: 8152

Affected script: include/html/resources_parser.inc.php

Solution:
Unique the array element on the resource objects. But, it introduces the new problem that when a same resource appears at different places in the content and users do want to have them with different alternatives. This solution makes this same resource only shows up once at "adapt content" page and only can have one alternative associate with. Table and scripts need to re-design to solve this problem, for example, include line number in table.

- Issue History
Date Modified Username Field Change
2008-10-24 09:22 greg New Issue
2008-10-24 09:22 greg Affects version => SVN
2008-10-28 16:25 silvia Note Added: 0003256
2008-10-28 16:25 silvia Status new => confirmed
2008-11-03 06:50 cindy Status confirmed => resolved
2008-11-03 06:50 cindy Fixed in Version => 1.6.2
2008-11-03 06:50 cindy Resolution open => fixed
2008-11-03 06:50 cindy Assigned To => cindy
2008-11-03 06:50 cindy Note Added: 0003277
2008-11-14 08:22 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker