MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003701ATutorContentpublic2009-01-23 05:322009-07-21 08:50
Reporterharris 
Assigned Toharris 
PrioritylowSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version1.6.3 
Summary0003701: LaTex support stopped.
DescriptionThe public mimetex server is for testing. For production, please read www.forkosh.com/mimetex.html and install mimetex.cgi on your own server.
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships

-  Notes
(0003552)
harris (developer)
2009-06-01 09:47

Keep getting this error still.

I am changing the parser in output.inc.php from rawurlencode to htmlentities, so then the cgi script won't recognize this is an external server call.

Uncomment line 375,835; and take out line 376,836 once we have our own mimetex cgi script on a server.

@svn 8510
(0003555)
harris (developer)
2009-06-01 10:54

seems like there is a script in their cgi script to blocks off text/html request.
only image/gif requests are authenticated.
(0003565)
harris (developer)
2009-06-02 09:32

the error only occurs on localhost/ 127.0.0.1

Seems to be fine otherwise.
(0003567)
harris (developer)
2009-06-03 06:22

replace htmlentities back with rawurlencode


svn: 8514
(0003601)
greg (administrator)
2009-06-08 07:53

Can we install mimetex.cgi on atutor.ca?
(0003602)
harris (developer)
2009-06-08 08:21
edited on: 2009-06-08 08:21

Yes I think so. As long as we download the script from their website. Execute the makefile, and dump the .cgi into our cgi-bin within apache. Then it should be fine.

(0003603)
greg (administrator)
2009-06-08 09:40

Can you set it up pls, and adjust the LaTeX location to point to it (in constants.inc.php I think)
(0003617)
harris (developer)
2009-06-11 11:32

svn:
8535
8536

- Issue History
Date Modified Username Field Change
2009-01-23 05:32 harris New Issue
2009-01-23 05:32 harris Affects version => SVN
2009-06-01 09:47 harris Note Added: 0003552
2009-06-01 10:54 harris Note Added: 0003555
2009-06-02 09:32 harris Note Added: 0003565
2009-06-02 09:32 harris Priority normal => low
2009-06-03 06:22 harris Note Added: 0003567
2009-06-08 07:53 greg Note Added: 0003601
2009-06-08 08:21 harris Note Added: 0003602
2009-06-08 08:21 harris Note Edited: 0003602
2009-06-08 09:40 greg Note Added: 0003603
2009-06-11 11:32 harris Status new => resolved
2009-06-11 11:32 harris Resolution open => fixed
2009-06-11 11:32 harris Assigned To => harris
2009-06-11 11:32 harris Note Added: 0003617
2009-06-12 09:32 greg Status resolved => new
2009-06-12 09:33 greg Status new => resolved
2009-06-12 09:33 greg Fixed in Version => 1.6.3
2009-07-21 08:50 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker