MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003720ATutorFile Storagepublic2009-03-02 07:022010-09-22 11:50
Reporterharris 
Assigned Toharris 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version2.0 
Summary0003720: File storage exhausted in memory
DescriptionFatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 8255806 bytes) in include\classes\zipfile.class.php on line 233

Notice allowed size 33554432 > 8255806


Reproduce this problem by:
---------------------------
My php.ini memory_size is at 32M
tried downloading a 15M .zip file ==> Ok
tried downloading a 13M .mp3 file ==> Ok
tried downloading a 13M .txt file ==> Ok
tried downloading a 15M .zip file + a 4kb jpg ==> Error
tried downloading a 13M .mp3 file + a 4kb jpg ==> Error
tried downloading a 13M .txt file + a 4kb jpg ==> Ok

Since mp3 and zip files are already compressed, gzcompress() can't reduce the file anymore. I am not too sure how gzcompress handles the zipping process. It might actually stores the file in memory several times before putting it all together, clogging up the memory.

If you make the memory_size to 4 times the download size, it would work. (It could be that gzcompress() loop through the process 4 times before compressing?)
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships
related to 0004289closedharris zipfile.class.php revised 

-  Notes
(0004283)
harris (developer)
2010-05-13 08:13

svn: 9930

- Issue History
Date Modified Username Field Change
2009-03-02 07:02 harris New Issue
2009-03-02 07:02 harris Affects version => SVN
2010-05-13 07:36 harris Relationship added related to 0004289
2010-05-13 08:13 harris Status new => resolved
2010-05-13 08:13 harris Resolution open => fixed
2010-05-13 08:13 harris Assigned To => harris
2010-05-13 08:13 harris Note Added: 0004283
2010-05-13 08:24 harris Status resolved => feedback
2010-05-13 08:24 harris Resolution fixed => reopened
2010-05-13 08:24 harris Status feedback => resolved
2010-05-13 08:24 harris Fixed in Version => 2.0
2010-05-13 08:24 harris Resolution reopened => fixed
2010-09-22 11:50 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker