MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003726ATutor- no cat -public2009-03-08 05:512009-07-21 08:50
ReporterIndieRect 
Assigned Toharris 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.6.1 
Target VersionFixed in Version1.6.3 
Summary0003726: Course stats: guests are counted twice
DescriptionWhen a guest accesses a public course the guest counter in AT_course_stats is incremented _twice_. That's because count_login() is called twice in bounce.php in that case.

Confirmed in 1.6.1. Should be true for 1.6.2 as relevant fragments haven't changed in SVN since.
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships

-  Notes
(0003533)
harris (developer)
2009-05-29 10:24

Confirmed and fixed, bounce.php line 300
changed
if (!$_SESSION['is_admin']) {
to
if (!$_SESSION['is_admin'] && $_SESSION['member_id'] > 0) {


svn: 8506

- Issue History
Date Modified Username Field Change
2009-03-08 05:51 IndieRect New Issue
2009-03-08 05:51 IndieRect Affects version => SVN
2009-05-29 10:23 harris Status new => assigned
2009-05-29 10:23 harris Assigned To => harris
2009-05-29 10:24 harris Status assigned => resolved
2009-05-29 10:24 harris Resolution open => fixed
2009-05-29 10:24 harris Note Added: 0003533
2009-06-12 09:32 greg Status resolved => new
2009-06-12 09:33 greg Status new => resolved
2009-06-12 09:33 greg Fixed in Version => 1.6.3
2009-07-21 08:50 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker