MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003825ATutorTests/Surveyspublic2009-06-15 10:392009-07-21 08:49
Reportercindy 
Assigned Tocindy 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.6.2 
Target VersionFixed in Version1.6.3 
Summary0003825: Test release option "Once quiz has been submitted and all questions have been marked" not work
Description"Release results - Once quiz has been submitted and all questions have been marked" still release the result once the quiz is submitted even though there are likert or open end questions in the quiz which need instructor's mark.

http://www.atutor.ca/view/7/17747/1.html [^]
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships

-  Notes
(0003622)
cindy (administrator)
2009-06-15 10:48

SVN revision: 8577

Affected scripts:
tools/take_test.php
tools/tests/view_results.php
include/classes/testQuestions.class.php
themes/default/test_questions/header.tmpl.php

Solution: The result is released right after submit is because atutor auto mark script always marked "likert" and "open end" questions to 0. The fix is to return null mark value on these question types. Also set tests_results.final_score to null when the test release option is "Once quiz has been submitted and all questions have been marked". If the release option is "Once quiz has been submitted", set final score with "likert" and "open end" questions marked 0.

Also modify test result header template to display "Unmarked" sign on the question result if the mark is null.
(0003623)
cindy (administrator)
2009-06-15 11:52

also need to fix take_test_q.php for test option "one question per page"
(0003624)
cindy (administrator)
2009-06-15 11:55

SVN revision: 8578

one more fixed:
tools/take_test.php

- Issue History
Date Modified Username Field Change
2009-06-15 10:39 cindy New Issue
2009-06-15 10:39 cindy Affects version => SVN
2009-06-15 10:48 cindy Status new => resolved
2009-06-15 10:48 cindy Fixed in Version => 1.6.3
2009-06-15 10:48 cindy Resolution open => fixed
2009-06-15 10:48 cindy Assigned To => cindy
2009-06-15 10:48 cindy Note Added: 0003622
2009-06-15 11:52 cindy Status resolved => feedback
2009-06-15 11:52 cindy Resolution fixed => reopened
2009-06-15 11:52 cindy Note Added: 0003623
2009-06-15 11:55 cindy Status feedback => resolved
2009-06-15 11:55 cindy Resolution reopened => fixed
2009-06-15 11:55 cindy Note Added: 0003624
2009-07-21 08:49 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker