MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003907ATutorPretty Urlpublic2009-08-05 08:482009-12-16 03:59
ReporterIndieRect 
Assigned Tocindy 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.6.3 
Target VersionFixed in Version1.6.4 
Summary0003907: Course home page tools disappear after rearranging them
DescriptionSteps to reproduce:
1. Log in as an admin.
2. Make sure that Pretty URL and/or Course Directory Name are enabled in System Preferences.
3. Log in as an instructor.
4. Create a new course and enter it.
5. Rearrange some home page tools by drag&dropping (detailed view).
6. Leave the course.
7. Enter the course again ? all the home page tools are missing.

Reason:
When the tools are rearranged AT_courses.home_links gets updated. If Pretty URL and/or Course Directory Name are enabled, those paths contain the course ID. Once written the paths cannot be parsed correctly on subsequent returns to the course.

Proposed solution:
Make sure that "bare" URLs (without IDs) are written to that field.
Additional InformationP.S. Is it OK to mark reports "major" in a sense of "urgent", like this one? Or is there a better way to signal higher priority of issue reports?
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships
related to 0004085closedcindy Detail view modules cannot be deleted 

-  Notes
(0003834)
greg (administrator)
2009-11-05 10:33

Urgent with no work around. In this case major but not urgent, since pretty URL can be turned off. Pretty URL needs a bit of work still. Should have most issues resolved for 1.6.4
(0004001)
cindy (administrator)
2009-12-15 08:52

SVN revision: 9041

Solution: modify backend php script that handles ajax call to move/delete modules, revert pretty urls back to regular urls before update them into database.

Affected scripts:
index.php
move_module.php
mods/_standard/student_tools/index.php

- Issue History
Date Modified Username Field Change
2009-08-05 08:48 IndieRect New Issue
2009-08-05 08:48 IndieRect Affects version => SVN
2009-11-05 10:28 greg Status new => assigned
2009-11-05 10:28 greg Assigned To => harris
2009-11-05 10:33 greg Note Added: 0003834
2009-12-15 06:32 greg Assigned To harris => cindy
2009-12-15 08:52 cindy Status assigned => resolved
2009-12-15 08:52 cindy Fixed in Version => 1.6.4
2009-12-15 08:52 cindy Resolution open => fixed
2009-12-15 08:52 cindy Note Added: 0004001
2009-12-15 08:54 cindy Relationship added related to 0004085
2009-12-16 03:59 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker