MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003911ATutorModulespublic2009-08-11 03:082009-12-01 08:41
ReporterIndieRect 
Assigned Tocindy 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.6.3 
Target VersionFixed in Version1.6.4 
Summary0003911: SQL queries preceeded by comments are skipped on module installation
DescriptionIf a module.sql file contains a "/*"-style comment (even on a separate line), during file parsing it gets prepended to the SQL query immediately following it instead of being discarded. Supposedly, function splitSqlFile() of include/classes/sqlutility.class.php is responsible for that bug.

Once that happens, function prefixQuery() tries to detect a SQL command (like INSERT, UPDATE, CREATE TABLE etc.) at the start of the query and fails because of a comment being there. As a result, TABLE_PREFIX is never appended to the query in question and the query fails too.
That can (and, in fact, did) have effects as adverse as failing to create a table for a module to store data in.

The bug doesn't happen with "#"-style comments.
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships

-  Notes
(0003851)
cindy (administrator)
2009-11-09 10:09

SVN revision: 8895

Solution: handle comment signs "/* ... */". Now, the accepted comment signs in atutor sql files are: "# ", "/* ... */", "--". All comment start signs must be at the beginning of the line.

Affected scripts: include/classes/sqlutility.class.php

- Issue History
Date Modified Username Field Change
2009-08-11 03:08 IndieRect New Issue
2009-08-11 03:08 IndieRect Affects version => SVN
2009-11-05 10:01 greg Status new => assigned
2009-11-05 10:01 greg Assigned To => cindy
2009-11-09 10:09 cindy Status assigned => resolved
2009-11-09 10:09 cindy Fixed in Version => 1.6.4
2009-11-09 10:09 cindy Resolution open => fixed
2009-11-09 10:09 cindy Note Added: 0003851
2009-12-01 08:41 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker