MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003912ATutorPatcherpublic2009-08-11 03:162010-12-20 10:20
ReporterIndieRect 
Assigned Tocindy 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.6.2 
Target VersionFixed in Version2.0.1 
Summary0003912: Patcher can't create directories
DescriptionAs of 1.6.2, I didn't find a way to create directories from within a patch.

That is, when a file in a non-existent directory is to be added by a patch, that directory is not created.
Worse still, a user gets confusing instructions to grant write permissions on a folder with empty path and cannot neither proceed further nor understand the real reason.

Or am I missing something?
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships

-  Notes
(0003831)
greg (administrator)
2009-11-05 09:58

Good idea. Maybe something for a future release.
(0004608)
harris (developer)
2010-09-13 11:14

I believe this is fixed now?
(0004651)
IndieRect (reporter)
2010-09-25 22:32

It's not. The same error message shows up.
(0004674)
cindy (administrator)
2010-09-30 10:20

SVN revision:

Solution:
Different actions depending on the file operation:
1. add: create the directory with 755 permission
2. delete: no action, continue
3. alter, overwrite: stop and display message "cannot proceed due to the absence of the file"

Affected script:
install/db/atutor_upgrade_2.0_to_2.0.1.sql
mods/_standard/patcher/classes/Patch.class.php

- Issue History
Date Modified Username Field Change
2009-08-11 03:16 IndieRect New Issue
2009-08-11 03:16 IndieRect Affects version => SVN
2009-11-05 09:58 greg Note Added: 0003831
2009-11-05 09:58 greg Status new => acknowledged
2010-09-13 11:14 harris Note Added: 0004608
2010-09-13 11:14 harris Status acknowledged => assigned
2010-09-13 11:14 harris Assigned To => cindy
2010-09-25 22:32 IndieRect Note Added: 0004651
2010-09-30 10:20 cindy Status assigned => resolved
2010-09-30 10:20 cindy Fixed in Version => 2.0.1
2010-09-30 10:20 cindy Resolution open => fixed
2010-09-30 10:20 cindy Note Added: 0004674
2010-12-20 10:20 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker