MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003926ATutor- no cat -public2009-08-28 05:452009-11-07 11:56
Reportercindy 
Assigned Tocindy 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.6.3 
Target VersionFixed in Version1.6.4 
Summary0003926: Replace deprecated php functions and usages from ATutor
DescriptionSet E_STRICT in php.ini, warning messages on deprecated functions and usages will be reported. All these should be replaced or resolved in the next release.

Examples:
http://www.atutor.ca/view/7/18494/1.html [^]
http://www.atutor.ca/view/3/17629/1.html [^]
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships
related to 0003958closedcindy Date() for timezone 
related to 0003959closedcindy assign value by referecne deprecated 

-  Notes
(0003775)
greg (administrator)
2009-09-20 06:17

also see http://www.atutor.ca/view/3/18684/1.html [^]
(0003782)
cindy (administrator)
2009-10-16 10:48

Have fixed some deprecated usages and functions that are reported from 5.3.0. It includes:

1. replace some eregi() with preg_match(), replace some eregi_replace() with preg_replace(). Need a thorough search on these functions to replace all of them;
2. thoroughly replaced all '=& new' with '= new'. This usage is deprecated too.

Tests are required for these changes.
(0003813)
greg (administrator)
2009-11-02 09:10

also see:
http://www.atutor.ca/view/3/18989/1.html [^]
(0003814)
harris (developer)
2009-11-02 10:27

vcard.php throws cannot redeclare quoted_printable_decode() error.

This is because the function is now included in the php library as of php 5.3.0+

svn: 8860
(0003843)
cindy (administrator)
2009-11-06 06:11

SVN revision: 8887

Solution:
1. replace ereg(), eregi() with preg_match()
2. replace ereg_replace(), eregi_replace() with preg_replace()

Affected scripts:
registration.php
admin/create_user.php
admin/config_edit.php
admin/edit_user.php
admin/admins/my_edit.php
admin/admins/create.php
admin/admins/edit.php
editor/edit_content.php
help/contact_support.php
include/classes/pclzip.lib.php
include/classes/XML/XML_HTMLSax/OS/Guess.php
include/phpCache/phpCache.inc.php
include/lib/enroll.inc.php
mods/_standard/patcher/patch_creator.php
mods/_standard/social/basic_profile.php
install/include/ustep3.php
install/include/ustep4.php
tools/course_tracker.php
tools/filemanager/top.php
tools/filemanager/zip.php
tools/tracker/export.php
tools/chat/start_transcript.php
users/email_change.php
users/profile.php

- Issue History
Date Modified Username Field Change
2009-08-28 05:45 cindy New Issue
2009-08-28 05:45 cindy Affects version => SVN
2009-09-20 06:17 greg Note Added: 0003775
2009-10-13 04:34 greg Relationship added related to 0003958
2009-10-13 04:39 greg Relationship added related to 0003959
2009-10-16 10:48 cindy Note Added: 0003782
2009-11-02 09:10 greg Note Added: 0003813
2009-11-02 10:27 harris Note Added: 0003814
2009-11-04 11:27 greg Status new => assigned
2009-11-04 11:27 greg Assigned To => cindy
2009-11-06 06:11 cindy Status assigned => resolved
2009-11-06 06:11 cindy Fixed in Version => 1.6.4
2009-11-06 06:11 cindy Resolution open => fixed
2009-11-06 06:11 cindy Note Added: 0003843
2009-11-07 11:56 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker