MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003971ATutor- no cat -public2009-10-21 08:572009-11-07 12:21
Reporterharris 
Assigned Toharris 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version1.6.4 
Summary0003971: Access for all fails validation in IMS CC
DescriptionWhen we export a package with AccessForAll support, and re-import this package into the system. We will get a validation error on the imsmanifest.xml

The AccessForAll we use is based on ISO, and the imsmanifest is from IMS Global. The validator doesn't contain the XSD for the AccessForAll.
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships

-  Notes
(0003792)
harris (developer)
2009-10-21 09:00

Fix: Either to include the XSD for AccessForAll or to by pass validation when AccessForAll is in the package.

We will by pass the validation for now because ISO doesn't have a XSD for AccessForAll yet. Also, if the export is from ATutor, we can generally assume that it's valid when we are importing it back to ATutor.

Note: If user decides to export AccessForAll content from ATutor and import them into other IMS system, it might fail.

8831

- Issue History
Date Modified Username Field Change
2009-10-21 08:57 harris New Issue
2009-10-21 08:57 harris Affects version => SVN
2009-10-21 09:00 harris Status new => resolved
2009-10-21 09:00 harris Resolution open => fixed
2009-10-21 09:00 harris Assigned To => harris
2009-10-21 09:00 harris Note Added: 0003792
2009-11-05 11:12 greg Status resolved => closed
2009-11-07 12:21 greg Status closed => resolved
2009-11-07 12:21 greg Fixed in Version => 1.6.4
2009-11-07 12:21 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker