MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003982ATutor- no cat -public2009-11-04 03:542009-11-07 12:09
ReporterIndieRect 
Assigned Tocindy 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.6.3 
Target VersionFixed in Version1.6.4 
Summary0003982: Gradebook update: students are compared by full name, not id
DescriptionIn 1.6.3, when updating or combining tests in gradebook, function get_studs_take_more_than_once() is used to check if those tests can be updated/combined.

For some reason, that function compares students' uniqueness by first_name + last_name, not by member_id.
Clearly, in large installations it leaves much space for collisions as there may well be several students with same first and last names.

Probably it was done because gradebook displays only first and last names everywhere, but I believe that had been a bad decision too.

My suggestions are:
1. Make that function check member_id.
2. Switch to displaying full student name everywhere in gradebook, preferably using get_display_name().
TagsNo tags attached.
Affects version1.6.4
SVN Revision#
Attached Files

- Relationships

-  Notes
(0003822)
cindy (administrator)
2009-11-05 06:35

SVN revision: 8869

Solution: check on member_id instead of first, last name in function get_studs_take_more_than_once() and accordingly change other scripts where this function is called.

Affected scripts:
mods/_standard/gradebook/lib/gradebook.inc.php
mods/_standard/gradebook/update_gradebook.php
mods/_standard/gradebook/edit_marks.php
mods/_standard/gradebook/verify_tests.php
mods/_standard/gradebook/gradebook_add_tests.php

- Issue History
Date Modified Username Field Change
2009-11-04 03:54 IndieRect New Issue
2009-11-04 03:54 IndieRect Affects version => SVN
2009-11-04 11:27 greg Status new => assigned
2009-11-04 11:27 greg Assigned To => cindy
2009-11-05 06:35 cindy Status assigned => resolved
2009-11-05 06:35 cindy Fixed in Version => 1.6.4
2009-11-05 06:35 cindy Resolution open => fixed
2009-11-05 06:35 cindy Note Added: 0003822
2009-11-05 11:11 greg Status resolved => closed
2009-11-07 12:08 greg Affects version SVN => 1.6.4
2009-11-07 12:08 greg Status closed => assigned
2009-11-07 12:09 greg Status assigned => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker