MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004076ATutorContentpublic2009-12-02 11:222013-02-28 18:05
Reportergreg 
Assigned Tocindy 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version1.6.4 
Summary0004076: side menu open when page loads
DescriptionThe side menu opens completely when a page loads, then closes based on the state. Is it possible to only open the parts of the menu contained in the state. Also the menu toggle images are retreived each time the page loads, rather than getting them from the cache.
TagsNo tags attached.
Affects versionSVN
SVN Revision#na
Attached Files

- Relationships

-  Notes
(0003972)
cindy (administrator)
2009-12-08 08:10

SVN revision: 9014

Solution: cache the side menu "content navigation". Only refresh the side menu when content title is modified/added/deleted. include/phpCache is not working. Replace it with include/classes/cacheLite

Affected scripts:
include/vitals.inc.php
include/class/ContentManager.class.php
include/class/cacheLite/cacheLite.class.php
include/class/cacheLite/Lite.php
include/lib/constants.inc.php
include/lib/output.inc.php
install/include/step5.php
install/include/ustep4.php
mods/_core/content/menu_inline_editor_submit.php
mods/_core/content/refresh_content_nav.php
editor/edit_content_folder.php
(0003975)
cindy (administrator)
2009-12-09 04:16

Revert the fixes which makes the content page load slow. The further investigation is required.
(0003976)
cindy (administrator)
2009-12-09 05:47

revert the fix back to use phpCache. The implementation of the new cacheLite somehow makes the content page load slow. The further investigation is required.
(0006138)
greg (administrator)
2013-02-28 14:32

seems to be resolved already
(0006169)
greg (administrator)
2013-02-28 18:05

Resolved for 2.1.1

- Issue History
Date Modified Username Field Change
2009-12-02 11:22 greg New Issue
2009-12-02 11:22 greg Affects version => SVN
2009-12-02 11:59 greg Status new => assigned
2009-12-02 11:59 greg Assigned To => cindy
2009-12-08 08:10 cindy Status assigned => resolved
2009-12-08 08:10 cindy Fixed in Version => 1.6.4
2009-12-08 08:10 cindy Resolution open => fixed
2009-12-08 08:10 cindy Note Added: 0003972
2009-12-09 04:16 cindy Status resolved => feedback
2009-12-09 04:16 cindy Resolution fixed => reopened
2009-12-09 04:16 cindy Note Added: 0003975
2009-12-09 05:47 cindy Note Added: 0003976
2013-02-28 14:32 greg SVN Revision# => na
2013-02-28 14:32 greg Note Added: 0006138
2013-02-28 14:32 greg Status feedback => assigned
2013-02-28 14:32 greg Status assigned => resolved
2013-02-28 14:32 greg Resolution reopened => fixed
2013-02-28 18:05 greg Note Added: 0006169
2013-02-28 18:05 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker