MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004195ATutorAdminpublic2010-04-10 09:452010-05-02 15:24
Reportergreg 
Assigned Tocindy 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version1.6.4 
Summary0004195: Admin enrollment privileges button
Descriptionproduces a blank screen.
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships

-  Notes
(0004130)
greg (administrator)
2010-04-10 10:41

needs a patch issued.
(0004132)
cindy (administrator)
2010-04-12 07:47

Solution: This bug only appears in 1.6.4. The reason is because the introduction of $course_id in header.inc.php and other scripts, which is to fix the bug that the search engine cannot index for public courses even when the pretty URL is turned on. However, the variable name $course_id is in conflict with the same variable name in admin enrolment scripts.

This bug does not appear in 2.0 since the variable name ambiguous problem has been addressed and var name $course_id used for search engine indexing fix has been renamed to $_course_id.

But applying the same fix for 2.0 into 1.6.4 would be bug-prone since quite a few crucial scripts (header.inc.php, sidemenu.inc.php, posts.inc.php etc.) need to be modified. So, the fix for 1.6.4 is to rename $course_id in enrolment scripts to $this_course_id.

Patch 07 has been issued on 1.6.4 for this fix.

Affected scripts:
admin/enrollment/index.php
admin/enrollment/enroll_edit.php
admin/enrollment/privileges.php
include/html/enrollment.inc.php
include/html/enroll_edit.inc.php
include/html/privileges.inc.php

- Issue History
Date Modified Username Field Change
2010-04-10 09:45 greg New Issue
2010-04-10 09:45 greg Affects version => SVN
2010-04-10 10:41 greg Note Added: 0004130
2010-04-10 10:41 greg Status new => assigned
2010-04-10 10:41 greg Assigned To => cindy
2010-04-12 07:47 cindy Status assigned => resolved
2010-04-12 07:47 cindy Fixed in Version => 1.6.4
2010-04-12 07:47 cindy Resolution open => fixed
2010-04-12 07:47 cindy Note Added: 0004132
2010-05-02 15:24 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker