MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004204ATutor- no cat -public2010-04-13 08:332010-05-02 15:24
Reportergreg 
Assigned Tocindy 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version1.6.4 
Summary0004204: enrollment errors with no student
Descriptionwhen viewing the enrolment manager as an instructor, when there are no students enrolled, mysql errors appear
Additional Information
Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /webserver/content/atutor.ca/docs/atutor/ATutor/include/vitals.inc.php on line 1233

Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /webserver/content/atutor.ca/docs/atutor/ATutor/include/html/enrollment.inc.php on line 207

Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /webserver/content/atutor.ca/docs/atutor/ATutor/include/html/enrollment.inc.php on line 207

Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /webserver/content/atutor.ca/docs/atutor/ATutor/include/html/enrollment.inc.php on line 207

Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /webserver/content/atutor.ca/docs/atutor/ATutor/include/html/enrollment.inc.php on line 207
TagsNo tags attached.
Affects version1.6.4
SVN Revision#
Attached Files

- Relationships

-  Notes
(0004135)
cindy (administrator)
2010-04-13 09:01

Solution: This bug is introduced by Patch 0000007.

related to: http://www.atutor.ca/atutor/mantis/view.php?id=4195 [^]

The reason is, the include script "include/html/enrollment.inc.php" is used by both admin and instructor enrolment pages. As the variable $course_id in this include script has been modified to $this_course_id, for the fix on 0004195. The same pass-in variable used in instructor enrolment script needs to be renamed accordingly.

Patch 0000008 has been issued for this fix.

Affected script: tools/enrolment/index.php
(0004136)
cindy (administrator)
2010-04-13 09:32

More scripts are involved.
(0004137)
cindy (administrator)
2010-04-13 09:32

More scripts affected:
tools/enrollment/privileges.php
tools/enrollment/enroll_edit.php

- Issue History
Date Modified Username Field Change
2010-04-13 08:33 greg New Issue
2010-04-13 08:33 greg Affects version => SVN
2010-04-13 09:01 cindy Status new => resolved
2010-04-13 09:01 cindy Fixed in Version => 1.6.4
2010-04-13 09:01 cindy Resolution open => fixed
2010-04-13 09:01 cindy Assigned To => cindy
2010-04-13 09:01 cindy Note Added: 0004135
2010-04-13 09:32 cindy Affects version SVN => 1.6.4
2010-04-13 09:32 cindy Status resolved => feedback
2010-04-13 09:32 cindy Resolution fixed => reopened
2010-04-13 09:32 cindy Note Added: 0004136
2010-04-13 09:32 cindy Status feedback => resolved
2010-04-13 09:32 cindy Resolution reopened => fixed
2010-04-13 09:32 cindy Note Added: 0004137
2010-05-02 15:24 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker