MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004283ATutorContentpublic2010-05-10 12:302010-09-22 11:50
Reportergreg 
Assigned Tocindy 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version2.0 
Summary0004283: edit folder break course id
DescriptionI imported a cartridge from open learn. I click on the folder toggles to display pages, then click on pages to display them. No Problem. But, if I click on a folder to edit it, then click on a sub page in the folder, I'm bounced back to MyStart.
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships

-  Notes
(0004274)
cindy (administrator)
2010-05-12 07:24

SVN Revision: 9922

Solution: the problem occurs when the pretty url is turned on. The path to "edit_content_folder.php" converted by url_rewrite() is incorrect. Since "edit content folder" should not be included in pretty url. Removing url_rewrite() fixes the problem.

Affected script: include/classes/ContentManager.class.php

- Issue History
Date Modified Username Field Change
2010-05-10 12:30 greg New Issue
2010-05-10 12:30 greg Affects version => SVN
2010-05-11 06:43 greg Status new => assigned
2010-05-11 06:43 greg Assigned To => cindy
2010-05-12 07:24 cindy Status assigned => resolved
2010-05-12 07:24 cindy Fixed in Version => 2.0
2010-05-12 07:24 cindy Resolution open => fixed
2010-05-12 07:24 cindy Note Added: 0004274
2010-09-22 11:50 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker