MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004508ATutorFile Managerpublic2010-08-24 04:322010-09-22 11:51
Reportergreg 
Assigned Togreg 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version2.0.1 
Summary0004508: Memory exhausted error when importing large files
DescriptionDespite upload/post files sizes set large, when uploading anything more than about 20mb, ATutor times out, producing an exhuasted memory error.

http://www.atutor.ca/view/3/20628/1.html [^]
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships

-  Notes
(0004592)
cindy (administrator)
2010-09-10 11:10

1. Memory exhausted issue at download a large CC has been fixed by reading and sending the download file in chunks, 3k at a time.
SVN revision: 10170
Affected: include/classes/zipfile.class.php

2. The blank page is given at importing a large common cartridge is because the script stops at unzipping the uploaded file. In more detail, stops at include/classes/pclzip.lib.php, line 3888. Function gzinflate() ceases without any return. This issue happens especially when there's a large file in CC. If the zip file is composed of many small files, should be ok. pclzip creators realize the issue as well. See:

http://www.phpconcept.net/pclzip/faq#faq03 [^]

The solution is to increase memory_limit in php.ini. To handle a 25M video in CC, memory_limit needs to be around 80M.

A FAQ in handbook needs to be set up to answer this type of user inquiry.
(0004619)
greg (administrator)
2010-09-21 12:14

Sort of fixed. PclZIP needs reworking to better use of memory. It zips into memory instead of temp files, thus is very memory intensive. A FAQ has been posted describing the issue with biug files.

- Issue History
Date Modified Username Field Change
2010-08-24 04:32 greg New Issue
2010-08-24 04:32 greg Affects version => SVN
2010-09-03 11:03 harris Status new => assigned
2010-09-03 11:03 harris Assigned To => harris
2010-09-03 11:05 harris Assigned To harris => cindy
2010-09-10 11:10 cindy Note Added: 0004592
2010-09-10 11:10 cindy Assigned To cindy => greg
2010-09-21 12:14 greg Status assigned => resolved
2010-09-21 12:14 greg Fixed in Version => 2.0.1
2010-09-21 12:14 greg Resolution open => fixed
2010-09-21 12:14 greg Note Added: 0004619
2010-09-22 11:51 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker