MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004528ATutorContentpublic2010-09-07 05:372011-08-29 14:11
Reportercindy 
Assigned Tocindy 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version2.0.3 
Summary0004528: Apply Armin's change on ContentManager.class.php
DescriptionArmin's change includes:

- pointing references to images to the theme/<themename>/images folder
- allowing the truncation in the sidenav menu being turned on/off via database entries
- change to the current selected element in the sidenav (gets color:red attached - I removed this and give it a class instead)

All changes can be turned on and off with settings in the table "config".
Additional InformationHello Greg and Cindy,

I introduced some changes to the ContentManager.class.php file. All changes can be turned on and off with settings in the table "config". If the setting is not found in the database the standard behaviour should
happen.

The three changes basically are:

- pointing references to images to the theme/<themename>/images folder
- allowing the truncation in the sidenav menu being turned on/off via database entries
- change to the current selected element in the sidenav (gets color:red attached - I removed this and give it a class instead)

Hope the changes are correct and working. I am not sure if I know how to call all lines I changed so there might be problems hiding.

Would be great if this change and the patch I submitted yesterday would make it into the SVN soon.

If there are questions feel free to ask.

Thanks

Armin
TagsNo tags attached.
Affects versionSVN
SVN Revision##
Attached Files? file icon ContentManager.class.php [^] (59,385 bytes) 2010-09-07 05:37

- Relationships
related to 0004167closedlaurelwilliams content menu truncate/full option 

-  Notes
(0004610)
cindy (administrator)
2010-09-13 12:04

SVN revision: 10181

2 out of 3 points have been applied into trunk:

1. Reference the tree icons used by "content navigation" to the theme image folder. If the icons are not in the theme folder, look up in atutor root image folder;
2. Associate the style of the current selected content to a class;

The truncation is not applied yet since it needs an according preference to switch on/off.

Affected scripts:
include/classes/ContentManager.class.php
jscripts/ATutorCourse.js
jscripts/ATutor_js.php
themes/default/styles.css
(0005257)
greg (administrator)
2011-08-29 14:00

Fixed 1 & 3, won't add truncation until Fluid comes up with a good solution
(0005258)
greg (administrator)
2011-08-29 14:11

2.0.3 bugs resolved and closed round 2

- Issue History
Date Modified Username Field Change
2010-09-07 05:37 cindy New Issue
2010-09-07 05:37 cindy File Added: ContentManager.class.php
2010-09-07 05:37 cindy Affects version => SVN
2010-09-07 05:38 cindy Category Glossary => Content
2010-09-08 09:59 greg Status new => assigned
2010-09-08 09:59 greg Assigned To => cindy
2010-09-13 12:04 cindy Note Added: 0004610
2010-09-29 06:14 greg Relationship added related to 0004167
2011-08-29 14:00 greg SVN Revision# => #
2011-08-29 14:00 greg Note Added: 0005257
2011-08-29 14:00 greg Status assigned => resolved
2011-08-29 14:00 greg Fixed in Version => 2.0.3
2011-08-29 14:00 greg Resolution open => fixed
2011-08-29 14:11 greg Note Added: 0005258
2011-08-29 14:11 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker