MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004573ATutorTests/Surveyspublic2010-10-08 08:222010-12-20 10:19
Reportergreg 
Assigned Tocindy 
PriorityhighSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version2.0.1 
Summary0004573: ordering questions are always in order.
DescriptionThere does not seem to be a way to randomize items in ordering questions. I recall there being a correct order select menu before each item in the question editor, but apparently that's not the case. Ordering items must then have been randomized when rendered in a test, but that does not seem to be working. Investigate and try to get this fix into the 2.0.1 release.
TagsNo tags attached.
Affects versionSVN
SVN Revision#
Attached Files

- Relationships

-  Notes
(0004697)
greg (administrator)
2010-10-08 08:22

see:
http://www.atutor.ca/view/3/20686/1.html [^]
(0004707)
IndieRect (reporter)
2010-10-09 04:29

Normally, an instructor enters answers in the correct order, and then the system shuffles them each time a student takes the test. The order that students get them in is not exactly random; rather, it's designed to be different for different people.

It works fine as of 1.6.3; didn't test it in later versions.
(0004723)
cindy (administrator)
2010-10-19 10:51

SVN revision: 10339

The reason of the problem is that PHP function array_rand() stops returning an array of shuffled array keys since version 5.2.10. The fix is to use srand() and shuffle() to shuffle the question order. This change also leads the change of "view result" of ordering question.

Affected scripts:
mods/_standard/tests/classes/testQuestions.class.php
mods/_standard/tests/edit_question_ordering.php
themes/default/test_questions/ordering_result.tmpl.php

- Issue History
Date Modified Username Field Change
2010-10-08 08:22 greg New Issue
2010-10-08 08:22 greg Affects version => SVN
2010-10-08 08:22 greg Note Added: 0004697
2010-10-09 04:29 IndieRect Note Added: 0004707
2010-10-12 06:08 greg Status new => assigned
2010-10-12 06:08 greg Assigned To => cindy
2010-10-19 10:51 cindy Status assigned => resolved
2010-10-19 10:51 cindy Fixed in Version => 2.0.1
2010-10-19 10:51 cindy Resolution open => fixed
2010-10-19 10:51 cindy Note Added: 0004723
2010-12-20 10:19 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker