MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004704ATutorContentpublic2011-01-20 13:592012-07-26 09:59
Reportercindy 
Assigned Tocindy 
PriorityhighSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.0.2 
Target Version2.0.3Fixed in Version2.1 
Summary0004704: Editor -> Accessibility icon does not work properly
DescriptionThe temporary html that is sent to AChecker, with the content to validate, only contains the content itself, without plugging into a html template. So, before AChecker starts validation, it wraps the content within <html>...</html>, which is not thorough enough. The fix is to,

mods/_core/editor/editor_tab_functions.inc.php -> write_temp_file() -> uncomment the part that the content is plugged into a template;

mods/_core/editor/accessibility.php -> add "offset=10" into $checker_url
TagsNo tags attached.
Affects versionSVN
SVN Revision#9c7b7d02b7b98f76e0ddb4e7642ef4c8d7ffff78
Attached Files

- Relationships

-  Notes
(0005045)
cindy (administrator)
2011-02-04 14:41

It turns out the comment-out the part in write_temp_file() to plug the content into a html template is because AChecker handles partial html by wrapping it into a simple template with doctype and <html>. This gets rid of the errors that is caused by the absence of <html>.

So the question is, should we let AChecker to handle the partial html, or, ATutor sends complete html to AChecker?
(0005229)
greg (administrator)
2011-08-25 09:22

bump
(0005244)
cindy (administrator)
2011-08-25 15:56

Note that accessibility checking doesn't work with localhost server. A message should be given if the validation is performed from localhost.

One issue of letting AChecker to check on partial html is that the returned report starts from line 2 instead of line 1. This issue has been reported in AChecker @ http://atutor.ca/atutor/mantis/view.php?id=4834 [^]
(0005680)
greg (administrator)
2012-07-23 10:54

AChecker tinymce plugin does not open when using IE9.
(0005683)
cindy (administrator)
2012-07-24 10:08

Solution: Fixed the IE9 issue by upgrading tinyMCE to the latest 1.5.5 version.

Affected:
jscripts/tiny_mce/*.*
(0005718)
greg (administrator)
2012-07-26 09:59

close for ATutor 2.1

- Issue History
Date Modified Username Field Change
2011-01-20 13:59 cindy New Issue
2011-02-04 14:41 cindy Note Added: 0005045
2011-07-18 16:27 greg Assigned To => cindy
2011-07-18 16:27 greg Status new => assigned
2011-08-25 09:22 greg Note Added: 0005229
2011-08-25 15:56 cindy Note Added: 0005244
2012-07-23 10:54 greg Note Added: 0005680
2012-07-24 10:08 cindy SVN Revision# => 9c7b7d02b7b98f76e0ddb4e7642ef4c8d7ffff78
2012-07-24 10:08 cindy Note Added: 0005683
2012-07-24 10:08 cindy Status assigned => resolved
2012-07-24 10:08 cindy Fixed in Version => 2.1
2012-07-24 10:08 cindy Resolution open => fixed
2012-07-26 09:59 greg Note Added: 0005718
2012-07-26 09:59 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker