MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004712ACheckerInterfacepublic2011-01-24 16:422011-01-25 13:16
Reportergreg 
Assigned Tocindy 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0004712: add prerequisite error message
Descriptionafter saving a new check, clicking on the add prerequisite button always generates an alert "you have unsaved changes" despite there being no unsaved changes.
TagsNo tags attached.
SVN Revision#458
Attached Files

- Relationships

-  Notes
(0004938)
cindy (administrator)
2011-01-25 11:51

The incorrect detection of unsaved data was due to the different newline characters from the page text area and db saved data. One uses "\n" while the other uses "\r". The solution is to remove all the newline characters before the string comparison.

Affected: themes/default/check/check_create_edit.tmpl.php
(0004945)
greg (administrator)
2011-01-25 13:16

closed for AChecker 1.1

- Issue History
Date Modified Username Field Change
2011-01-24 16:42 greg New Issue
2011-01-24 16:42 greg Status new => assigned
2011-01-24 16:42 greg Assigned To => cindy
2011-01-25 11:51 cindy SVN Revision# => 458
2011-01-25 11:51 cindy Note Added: 0004938
2011-01-25 11:51 cindy Status assigned => resolved
2011-01-25 11:51 cindy Fixed in Version => 1.1
2011-01-25 11:51 cindy Resolution open => fixed
2011-01-25 13:16 greg Note Added: 0004945
2011-01-25 13:16 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker