MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004771ATutorExport Contentpublic2011-06-03 10:542013-02-28 18:05
Reportergreg 
Assigned Toharris 
PriorityhighSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version2.1 
Summary0004771: Implement $IMS-CC-FILEBASE$ CC Paths
DescriptionThe $IMS-CC-FILEBASE$ is not working properly for rewriting resource paths within content pages on export and import to reset paths to the appropriate location of resource files on a given system.
TagsNo tags attached.
Affects versionSVN
SVN Revision##
Attached Filesxls file icon atutor203_imscc10_validation.doc.xls [^] (20,480 bytes) 2011-08-24 12:47

- Relationships

-  Notes
(0005086)
greg (administrator)
2011-06-03 10:55

NOTE this also applies to css files referenced within content.
(0005220)
greg (administrator)
2011-08-24 10:29

bump
(0005222)
harris (developer)
2011-08-24 12:52
edited on: 2011-08-24 12:52

Css refs fail because of the ../ paths, also the validator fails on two 1003 errors that reference non-existent urls

1003 error: The two urls are the ones listed in the packages. There isn't much we can do about it if the provided packages contains 404 links in the first place...

(0005223)
greg (administrator)
2011-08-24 12:54

as long as the test files work, that's all we need
(0005226)
harris (developer)
2011-08-24 17:19

Within the packages, the content (.html) files contains links that might result a 404, or a 403. In this case, the validator returns an error when we add these links to our meta data. I think the reason why we have these files in our manifest is because of accessforall. Accessforall parse the content and find replacement for all links, including URLs. Since these links are included as "resources", and are actually 404,403, they are not passing the validation.
(0005304)
harris (developer)
2011-08-30 14:19

These links will no longer get added if it's not accessforall export.
(0006102)
greg (administrator)
2013-02-20 11:58

Previously Resolved
(0006183)
greg (administrator)
2013-02-28 18:05

Resolved for 2.1.1

- Issue History
Date Modified Username Field Change
2011-06-03 10:54 greg New Issue
2011-06-03 10:55 greg Note Added: 0005086
2011-07-18 16:15 greg Assigned To => harris
2011-07-18 16:15 greg Status new => assigned
2011-08-24 10:29 greg Note Added: 0005220
2011-08-24 12:47 harris File Added: atutor203_imscc10_validation.doc.xls
2011-08-24 12:52 harris Note Added: 0005222
2011-08-24 12:52 harris Note Edited: 0005222 View Revisions
2011-08-24 12:52 harris Note Edited: 0005222 View Revisions
2011-08-24 12:54 greg Note Added: 0005223
2011-08-24 17:19 harris Note Added: 0005226
2011-08-30 14:19 harris Note Added: 0005304
2013-02-20 11:58 greg SVN Revision# => #
2013-02-20 11:58 greg Note Added: 0006102
2013-02-20 11:58 greg Status assigned => resolved
2013-02-20 11:58 greg Fixed in Version => 2.1
2013-02-20 11:58 greg Resolution open => fixed
2013-02-28 18:05 greg Note Added: 0006183
2013-02-28 18:05 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker