MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004879AContentUser Interfacepublic2011-10-06 16:322013-03-15 10:58
ReporterIntuitiveNipple 
Assigned Toharris 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformApache 2.2, PHP 5.3.2OSUbuntu LinuxOS Version 10.04
Product Version 
Target VersionFixed in Version1.2 
Summary0004879: Pop-up window for home/prog.php: iframe contents are HTTP 404 Not Found
DescriptionI noticed whilst doing all the testing for the Import IMS CC, that when it fails the associated pop-up window for 'home/prog.php' gets a 404 Not Found error in the iframe after a refresh... it's hard to see the error report since the iframe dimensions clip the server error message into a 100x25 px space.
Steps To ReproducePerform a long-running operation that puts up the progress window.
Additional InformationThe problem is the relative URI for the iframe src="<?php echo TR_BASE_HREF; ?>home/prog.php" which assumes the progress window was opened from the 'root' of the installation. For an installation in '/acontent/' his generates:

"acontent/home/home/prog.php"

The iframe's 'root' is the 'home/' directory since it is loaded by the same document as the parent window (home/prog.php).

The fix is to remove the "home/" prefix from the iframe src attribute since it is part of the TR_BASE_HREF when generated from 'home/prog.php' itself.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0005460)
IntuitiveNipple (developer)
2011-10-06 16:37
edited on: 2011-10-07 08:25

I'm not clear if my fix is correct in all circumstances although from analysing the code it looks to be correct.

The patch is available from:

git pull git://iam.tj/acontent.git [^] issue_4879

gitweb: http://iam.tj/gitweb/?p=acontent.git;a=commit;h=cd41f3155e177e555e19bdefa66a8ea7104134f3 [^]

(0005461)
IntuitiveNipple (developer)
2011-10-06 16:42

Correction to my "Additional Information".

The problem is the relative URI for the iframe src="home/prog.php?frame=1" which assumes the progress window was opened from the 'root' of the installation. For an installation in '/acontent/' this is correct, but when loaded from the parent window which is itself generated by "home/prog.php" the relative reference effectively becomes "/acontent/home/home/prog.php"

Removing the hard-coded "home/" from the iframe src attribute and using prefixing with "<?php echo TR_BASE_HREF; ?>" should ensure the correct path is generated.
(0005487)
harris (developer)
2011-10-26 12:36

Merged to master.

https://github.com/atutor/AContent/pull/3 [^]
(0006251)
greg (administrator)
2013-03-15 10:58

fixed in 1.3

- Issue History
Date Modified Username Field Change
2011-10-06 16:32 IntuitiveNipple New Issue
2011-10-06 16:37 IntuitiveNipple Note Added: 0005460
2011-10-06 16:38 IntuitiveNipple Note Edited: 0005460 View Revisions
2011-10-06 16:42 IntuitiveNipple Note Added: 0005461
2011-10-07 08:25 IntuitiveNipple Note Edited: 0005460 View Revisions
2011-10-26 12:36 harris Note Added: 0005487
2011-10-26 12:36 harris Status new => resolved
2011-10-26 12:36 harris Fixed in Version => 1.2
2011-10-26 12:36 harris Resolution open => fixed
2011-10-26 12:36 harris Assigned To => harris
2013-03-15 10:58 greg Note Added: 0006251
2013-03-15 10:58 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker