MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005004ATutorMultiSitepublic2012-06-27 13:452013-02-28 18:05
Reportercindy 
Assigned Togreg 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.1 
Target VersionFixed in Version2.1.1 
Summary0005004: Implement upgrade process
DescriptionSome thoughts of how to upgrade the multisites:

1. Main site admin unzip the latest ATutor release and place it in the same directory that contains the old main site and subsites.

2. go to upgrade script. The first upgrade step lists all the directories at the same level of ATutor root, with one checkbox besides each directory.

3. The admin selects the old main site and subsites to upgrade.

4. Upgrade process reads config from each site and upgrade its database.

Another thought is, only upgrades the main site, keeps the old main site and continuing support subsites with the old version until subsite admins decide to upgrade to the new version.
TagsNo tags attached.
Affects versionSVN
SVN Revision#1af0669d47a5867d1585585c0d34ad8ad1723687
Attached Files

- Relationships
duplicate of 0005192closedcindy Upgrade subsites 

-  Notes
(0006106)
cindy (administrator)
2013-02-22 10:03

Commit#:

"manage_multi" repo: e76d3e9fc21f41c0ccbc0c2d18c8922a9757bcce
"atutor" repo: 372b3855c8818184fa0d7d6367b069f21fcbd927

Solution:
Added a new tab "upgrade subsites" in manage_multi module for the multisite administrator to upgrade subsites. The upgrade status is reported as regular information message at the end of the process.

Atutor repo is also modified to extract the common upgrade functionality, which can be shared by main site and subsites upgrade, into include/install/upgrade.inc.php

One left issue is that the mysql account created by ATutor version 2.1 does not have privilege to alter table which prevents the database upgrade. This issue is partially fixed by granting all privilege to mysql accounts that are created after 2.1. However, in terms of the other part of the fix that is to deal with old mysql accounts, subsite upgrade process will report an error at the discovery of insufficient privileges and guide the admins with more instructions of how to grant proper privileges. Greg is going to work on the "more instructions".
(0006114)
greg (administrator)
2013-02-28 12:21

Added upgrade process to Manage Multisite module
(0006177)
greg (administrator)
2013-02-28 18:05

Resolved for 2.1.1

- Issue History
Date Modified Username Field Change
2012-06-27 13:45 cindy New Issue
2013-02-11 13:39 greg Relationship added duplicate of 0005192
2013-02-22 10:03 cindy Note Added: 0006106
2013-02-22 10:04 cindy Assigned To => greg
2013-02-22 10:04 cindy Status new => assigned
2013-02-28 12:21 greg SVN Revision# => 1af0669d47a5867d1585585c0d34ad8ad1723687
2013-02-28 12:21 greg Note Added: 0006114
2013-02-28 12:21 greg Status assigned => resolved
2013-02-28 12:21 greg Fixed in Version => 2.1.1
2013-02-28 12:21 greg Resolution open => fixed
2013-02-28 18:05 greg Note Added: 0006177
2013-02-28 18:05 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker