MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005016ATutorInstallationpublic2012-07-06 09:292012-07-26 09:59
Reportergreg 
Assigned Tocindy 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.1 
Target VersionFixed in Version2.1 
Summary0005016: Failed write mysql pwd to config.inc
DescriptionOn completion of the install and clicking the Login button on the last screen of the installer, ATutor opens with a "Cannot connect to database error". This appears to be because the db password is not written into the config.inc.php file.
TagsNo tags attached.
Affects versionSVN
SVN Revision#69f3a338d9d51c13c507ae689046a008f7f45a67
Attached Files

- Relationships
related to 0005017closedcindy addslashes fails when magic_quotes off 

-  Notes
(0005622)
greg (administrator)
2012-07-09 14:18

Tested on my Mac dev env, seems to write the mysql pwd to config.inc.php okay.
(0005623)
greg (administrator)
2012-07-09 15:59

The problem originates with the $addslashes() function, which seems to dislike the mysql_real_escape_string() function. If addslashes() is removed, everything installs fine.

The problem occurs on my Unbuntu machine, using php 5.3.5-1ubuntu7.8 but not with PHP 5.3.6 on Mac.
(0005624)
greg (administrator)
2012-07-09 16:11

same problem occurs with mysqli_real_escape_string()
(0005695)
cindy (administrator)
2012-07-25 11:51

The error is caused by undefined var $addslashes. Fixed by removing $addslashes as it's unnecessary if the data is not to be inserted into db.

Affected: include/install/install.inc.php
(0005710)
greg (administrator)
2012-07-26 09:59

close for ATutor 2.1

- Issue History
Date Modified Username Field Change
2012-07-06 09:29 greg New Issue
2012-07-09 14:18 greg Note Added: 0005622
2012-07-09 15:59 greg Note Added: 0005623
2012-07-09 16:11 greg Note Added: 0005624
2012-07-10 12:52 greg Relationship added related to 0005017
2012-07-10 13:20 greg Assigned To => cindy
2012-07-10 13:20 greg Status new => assigned
2012-07-25 11:51 cindy SVN Revision# => 69f3a338d9d51c13c507ae689046a008f7f45a67
2012-07-25 11:51 cindy Note Added: 0005695
2012-07-25 11:51 cindy Status assigned => resolved
2012-07-25 11:51 cindy Fixed in Version => 2.1
2012-07-25 11:51 cindy Resolution open => fixed
2012-07-26 09:59 greg Note Added: 0005710
2012-07-26 09:59 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker