MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005027ATutorMultiSitepublic2012-07-19 13:252012-07-26 09:59
Reportergreg 
Assigned Tocindy 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version2.1 
Summary0005027: multisite subsite modules not found
DescriptionI installed the bigbluebutton-2 module. It is present in the subsite mods/ directory, though when accessby browser, it results in a 404.
TagsNo tags attached.
Affects versionSVN
SVN Revision#Listed in notes
Attached Files

- Relationships

-  Notes
(0005662)
greg (administrator)
2012-07-19 13:27

Seems to be looking in the main site for addonb mods

[Thu Jul 19 13:25:42 2012] [error] [client 127.0.0.1] File does not exist: /var/www/sites/localhost.local/mods/bigbluebutton, referer: http://greg.local/mods/_core/modules/index.php?enabled=1;disabled=1;missing=1;partially_uninstalled=1;standard=1;extra=1 [^]
[Thu Jul 19 13:26:37 2012] [error] [client 127.0.0.1] File does not exist: /var/www/sites/localhost.local/mods/bigbluebutton
(0005693)
cindy (administrator)
2012-07-25 10:42

Related commits:
4ed1e78d1bf985041cdf0ce1d0a686fc29a57d0a
555b843ed9cf40c3ddf1dbd8dd134c2f7c23c42b
150581d61f7bdd0cf667b0a152fb72bb25ddf2b4
c3feaac6eb1fcd1949d8b5d31e0d066284f6c076

Solution:
Removed the use of sub sites' own mods directory. The module installation and load from subsites' own directory cannot be implemented until the core module handler is extended to accept the modules from different directories. The solution is to have main site mods directory containing all the available modules but in module.xml of each module, using a <private> section to identify if it's a public and private module. The subsites are not allowed to install new modules by uploading a zip file or remotely fetching from update.atutor.ca since they don't have write permission to main site mods directory. However, the subsites can send a request to main site administrator to request a module installation.

Affected scripts:
mods/_core/modules/classes/Module.class.php
mods/_core/modules/classes/ModuleParser.class.php
mods/_core/modules/install_modules.php
themes/default/admin/modules/install_modules.tmpl.php
themes/mobile/admin/modules/install_modules.tmpl.php
themes/simplified_desktop/admin/modules/install_modules.tmpl.php
(0005712)
greg (administrator)
2012-07-26 09:59

close for ATutor 2.1

- Issue History
Date Modified Username Field Change
2012-07-19 13:25 greg New Issue
2012-07-19 13:25 greg Status new => assigned
2012-07-19 13:25 greg Assigned To => cindy
2012-07-19 13:27 greg Note Added: 0005662
2012-07-25 10:42 cindy SVN Revision# => Listed in notes
2012-07-25 10:42 cindy Note Added: 0005693
2012-07-25 10:42 cindy Status assigned => resolved
2012-07-25 10:42 cindy Fixed in Version => 2.1
2012-07-25 10:42 cindy Resolution open => fixed
2012-07-26 09:59 greg Note Added: 0005712
2012-07-26 09:59 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker