MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005041ATutorPreferencespublic2012-07-26 10:282012-08-31 17:48
Reportergreg 
Assigned Tocindy 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version2.1Fixed in Version2.1 
Summary0005041: Direct Jump pref setting not working
DescriptionWhen direct jump preferecne is turned on, user is always sent to the course hopme page, instead of the same tool in the target course.
TagsNo tags attached.
Affects versionSVN
SVN Revision#bcdc05ce3a9963ddd7d91b5ee1fd92aa157df54e
Attached Files

- Relationships

-  Notes
(0005789)
cindy (administrator)
2012-07-26 15:40

The "direct jump" works fine. The problem was that the enabling of this pref is not saved and populated properly into session prefs.

Another finding with the behavior of enabled direct jump pref is that, if you are in the content editor of one course and jump to another course, the page won't be re-directed to the content editor again, instead users get to the course home page, which is because accessing content editor requires a content id in the url which is apparently missing in another course. However, if you were at forum index page or file storage index page, the redirection would be maintained when jumping to another course.

Affected: mods/_core/users/lib/pref_tab_functions.inc.php
(0005823)
greg (administrator)
2012-08-31 17:48

closed in ATutor 2.1

- Issue History
Date Modified Username Field Change
2012-07-26 10:28 greg New Issue
2012-07-26 10:28 greg Status new => assigned
2012-07-26 10:28 greg Assigned To => cindy
2012-07-26 15:40 cindy SVN Revision# => bcdc05ce3a9963ddd7d91b5ee1fd92aa157df54e
2012-07-26 15:40 cindy Note Added: 0005789
2012-07-26 15:40 cindy Status assigned => resolved
2012-07-26 15:40 cindy Fixed in Version => 2.1
2012-07-26 15:40 cindy Resolution open => fixed
2012-08-31 17:48 greg Note Added: 0005823
2012-08-31 17:48 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker