MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005043ATutorPretty Urlpublic2012-07-26 13:192012-08-31 17:48
Reportercindy 
Assigned Tocindy 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.0.3 
Target Version2.1Fixed in Version2.1 
Summary0005043: Some special characters in course name break pretty url
Description1. go to admin "system preference" page, enable pretty url and course directory name;
2. login as a instructor, go to "Properties" page, defined a course name as "main-site";
3. Click on any content, a blank page is thrown.

This is caused by the char "-" in the course name. Need to guard the course name before saving it at course "Properties" page.
TagsNo tags attached.
Affects versionSVN
SVN Revision#d225acef654423ff818087e8c170482b2b556a5a
Attached Files

- Relationships

-  Notes
(0005788)
cindy (administrator)
2012-07-26 13:56

Enhance the validation of course directory name that is defined in course properties page and used by pretty url.

Affected scripts:
mods/_core/courses/lib/course.inc.php
mods/_core/properties/lib/course.inc.php
themes/default/admin/courses/edit_course.tmpl.php

Added the new language token "course_dir_name_contain_only" and modified "AT_ERROR_COURSE_DIR_NAME_INVALID" in both SVN and 2.1 central db.
(0005824)
greg (administrator)
2012-08-31 17:48

closed in ATutor 2.1

- Issue History
Date Modified Username Field Change
2012-07-26 13:19 cindy New Issue
2012-07-26 13:19 cindy Status new => assigned
2012-07-26 13:19 cindy Assigned To => cindy
2012-07-26 13:56 cindy SVN Revision# => d225acef654423ff818087e8c170482b2b556a5a
2012-07-26 13:56 cindy Note Added: 0005788
2012-07-26 13:56 cindy Status assigned => resolved
2012-07-26 13:56 cindy Fixed in Version => 2.1
2012-07-26 13:56 cindy Resolution open => fixed
2012-08-31 17:48 greg Note Added: 0005824
2012-08-31 17:48 greg Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker